Opened 13 years ago

Closed 12 years ago

#997 closed defect (wontfix)

Editor size not being set properly

Reported by: xinha@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: major Keywords:
Cc:

Description

2 problems, both with the same short summary.

I am using version 0.92

Take a look at: http://www.clickprovince.com/samplepage.htm
This has 2 xinha text areas.

  1. The text area in the main area (the left text area) you can see scroll bars but they are not filling the available area. It is as though the iframe is only filling part of the screen. However, if you maximise the edit area then restore, it will fill the edit space.
  1. When using a limited area (as the box on the right), the editor toolbar takes up so much space, leaving very little to play with. This is fine in firefox, but is a problem in I.E.

Other problems I have seen, but cannot reproduce easily.

  1. If it is in a complex page, (loads of nested tables etc.) then click into the editor, the location bar at the bottom goes really wide, listing the location from the page level not the editor level.
  1. If the page has flash movies on, then click maximise editor, the flash movies show through.

Something else I would like to request...
When you have more than one editor on the page, how about having the toolbar to be a common toolbar. See the page above... having more than one toolbar for more than one editor fills the page up a bit. Having one shared toolbar would greatly save screen estate. (If the toolbar can float at the top or bottom of the browser, that would be even better.).

Thanks.

Change History (1)

comment:1 Changed 12 years ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

CLosing wontfix.

1 & 2: are just height and width specification - see the config
3: this is a browser/flash/plugin problem, they are "windowed" objects and always set above html content. not something we can fix.

Note: See TracTickets for help on using tickets.