Opened 12 years ago

Closed 11 years ago

#991 closed defect (worksforme)

Text formatting wrong in IE on initial edit of field

Reported by: richjanzen@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc:

Description

I found some strange behaviour with text formatting in IE 6 (works fine in Firefox) within a Xinha editor. I load a page with just one editor and then type some text (all on one line): "This is some text ". Currently the cursor is at the space after the word 'text' (no selection). If I then press any of the bold, italics, underline, or strikethrough buttons on my toolbar, the previous word receives the text formatting as well as any text I type beyond that. In Firefox, it works as I would expect, where if I pressed the bold button, only text that I typed afterwards would be bolded, until I pressed the bold button again to turn it off.

I have also found that this behaviour only occurs for an empty editor (if you load data into your editor when the page is loaded, this behaviour does not occur), and only while you are still on one line (as soon as you hit enter, your text gets wrapped in paragraph <p> tags), which makes me wonder if it has something to do with the cursor being at the end of all text in the textarea.

Change History (1)

comment:1 Changed 11 years ago by ray

  • Resolution set to worksforme
  • Status changed from new to closed

cannot reproduce this

Note: See TracTickets for help on using tickets.