Opened 10 years ago

Closed 10 years ago

#979 closed defect (invalid)

improve checking for non-supported browsers

Reported by: ray Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

As far as I remember HTMLArea was designed to "degrade gracefully" to a normal textarea. However, at the moment

  • there's JS errors all over the place because of references to object properties that are not defined due to a check for browser support only in one place
  • the plugins are loaded, wasting bandwidth
  • Safari falsely identifies itself as Gecko

Change History (3)

comment:1 Changed 10 years ago by ray

  • Resolution set to fixed
  • Status changed from new to closed

fixed rev [767]

comment:2 Changed 10 years ago by guest

  • Resolution fixed deleted
  • Status changed from closed to reopened

I want to select the textarea and give the tags Bold,Italics and Underline to the selcted text .For eg:- like this kind of a textarea

comment:3 Changed 10 years ago by ray

  • Resolution set to invalid
  • Status changed from reopened to closed

Interesting idea, but this has nothing to do with the topic of this ticket and is IMHO by far not in the focus of Xinha development, at least not in near time

Note: See TracTickets for help on using tickets.