Opened 8 years ago

Closed 7 years ago

#912 closed defect (fixed)

Cell merge broken

Reported by: guest Owned by: gogo
Priority: normal Milestone:
Component: Plugin_TableOperations Version: trunk
Severity: normal Keywords: table merge firefox
Cc:

Description

Clicking on a single cell in the table and then clicking on the merge button will produce the following error in Firefox:

Error: cells has no properties
Source File: xinha/plugins/TableOperations/table-operations.js
Line: 652

this relates to:

var cells = rows[i];
for (var j = 0; j < cells.length; ++j) {

j && (HTML += "&nbsp;");
var cell = cells[j];
HTML += cell.innerHTML;

(i
j) && (cell.parentNode.removeChild(cell));

}

In Internet Explorer 6 this will produce a prompt to ask how many cells to merge. (This is also broken in IE7, see ticket #908).

This is using the files as of revision [673]

David G. Paul (jedi58)

Change History (7)

comment:1 Changed 8 years ago by jedi58

just noticed the block of code has a FIXME for Mozilla, so this can probably be closed - probably a ticket somewhere for it that I couldn't find

comment:2 Changed 8 years ago by ray

  • Resolution set to fixed
  • Status changed from new to closed

rev [675]: catch the error and prompt the user to select more than one cell

I think better would be to disable the button in this case, though

comment:3 Changed 7 years ago by jedi58

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is now broken in IE6, have checked against the demo page for Xinha Nightly too and is also broken there.

comment:4 Changed 7 years ago by guest

Note: bug caused by the addition of the dialog box - no matter how many cells are selected it just asks to select some.

comment:5 Changed 7 years ago by ray

jedi58: What is broken, please specify. I have changed only the non-IE block

guest: works for me

comment:6 Changed 7 years ago by ray

#908 contains a propable fix for this

comment:7 Changed 7 years ago by wymsy

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.