Opened 12 years ago

Closed 12 years ago

#906 closed defect (fixed)

Intermitent JavaScript error in IE

Reported by: guest Owned by: gogo
Priority: low Milestone:
Component: Xinha Core Version: trunk
Severity: minor Keywords: mozKey ie6
Cc:

Description

Sometimes I find that alt-tabbing between a page with Xinha on in IE, and another window will eventually cause a JavaScript? error to occur - it seems to be caused by it reaching:

else if ( keyEvent )
{

this.mozKey( ev, keyEvent );

}

I've changed it to and the problem seems to have gone:

else if ( keyEvent && this.is_gecko )
{

this.mozKey( ev, keyEvent );

}

This bug was found using IE6/win, and has not been tested under IE7.

Change History (1)

comment:1 Changed 12 years ago by ray

  • Resolution set to fixed
  • Status changed from new to closed

fixed rev [655]

Note: this.is_gecko is undefined, thus disabling the whole function. Actually it's Xinha.is_gecko

Note: See TracTickets for help on using tickets.