Opened 8 years ago

Closed 7 years ago

#846 closed defect (wontfix)

lots of javascript errors when using Web Developer debugging tools

Reported by: guest Owned by: gogo
Priority: normal Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: normal Keywords: javascript debugger
Cc:

Description

When I'm developing I like to have the Web Developer's extension check for Javascript errors & warnings. http://chrispederick.com/work/webdeveloper/ (works with FF, Mozilla, Seamonkey & Flock).

In FF these JS options are in Tools / Web Developer / Options / Options / Miscellaneous. If I have them switched on the Xinha throws up quite a few errors. I don't think most of them are anything to do with my site though.

Here's a sample

Warning: anonymous function does not always return a value

Source File: http://localhost/XINHA/htmlarea.js
Line: 532 Source Code: };

Warning: anonymous function does not always return a value

Source File: http://localhost/XINHA/htmlarea.js
Line: 714 Source Code: };

Warning: anonymous function does not always return a value

Source File: http://localhost/XINHA/htmlarea.js
Line: 1406 Source Code: };

...

Warning: redeclaration of function stripTag

Source File: http://localhost/XINHA/htmlarea.js
Line: 2323, Column: 13 Source Code: function stripTag(el)

There lots of these too

Warning: reference to undefined property a[i]

Source File: http://localhost/XINHA/htmlarea.js Line: 631

Having the Javascript console pop up with so many errors with Xinha makes it very awkward to have the debugger on when working on other stuff. I will probably have a go at fixing some of them - and probably fail.

Sorry if I give this the worong properties - no idea if I have trunk or unified backend. Got it from http://xinha.gogo.co.nz/xinha-nightly.zip just a few days ago although there don't seem to be any very recent files in it.

Change History (1)

comment:1 Changed 7 years ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

Not a bug (just a sensitive linter that Firefox plugin).

Note: See TracTickets for help on using tickets.