Opened 13 years ago

Closed 13 years ago

#819 closed defect (invalid)

Content not submitted in Firefox 1.5

Reported by: mikael@… Owned by: gogo
Priority: highest Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

Hello,

I have a strange problem with Xinha in Firefox 1.5.04
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508)

The content wont be submitted:

http://www.argus.nu/notworking.php

It works great in Internet Explorer.
Any help in this matter are highly appreciated.

Change History (3)

comment:1 Changed 13 years ago by guest

  • Resolution set to fixed
  • Status changed from new to closed

I think the problem is your form tag as you have placed it somewhere inbetween table tags:

<table width=100%>
<tr><td>
<form action="notworking.php" method="post" name="skrivtext">
<tr><td>

I'm pretty sure it will work if you do it like this

<form action="notworking.php" method="post" name="skrivtext">
<table width=100%>
<tr><td>
<textarea ...
</table>
</form>

By the way, would you mind sharing your insert/edit snippets plugin? Seems like a perfect addition to Xinha on PHP systems (well at least I really could use it ;D ).

comment:2 Changed 13 years ago by guest

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 13 years ago by mokhet

  • Resolution set to invalid
  • Status changed from reopened to closed

Well, the first comment is totally right. With invalid markup you cant except consistent result. I have tried the original markup from argus.nu and as stated, it's not sending content when submit.

However, once the <form> tag is correctly inserted in the markup (second comment), it's working like a charm
http://mokhet.com/xinha/examples/819.php

So, since it's not Xinha related but good HTML practices related, i'm closing this ticket.

Note: See TracTickets for help on using tickets.