Opened 13 years ago

Closed 13 years ago

#810 closed defect (fixed)

Firefox freeze when i want Winha to load in more than one textarea

Reported by: laurent.hohl@… Owned by: gogo
Priority: highest Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: critical Keywords: firefox freeze more than one textarea
Cc:

Description

I'm always have firefox 1.5.0.4 freezing when i try to load Xinha in more than one textarea. It doesn't work even with you example page.

Works fine with IE 6.

Change History (5)

comment:1 Changed 13 years ago by nico@…

In my case the cpu goes to 100% and stays there.
This issue is caused by the doc.write while FF is loading a html page (popups/blank.html). When the iframe.src is not set then FF works fine.
IE requires a src attribute otherwise it breaks in https or with absolute URLs

The fix would be to add a check for IE for the src attribute (htmlarea.js:1580)

create the IFRAME & add to container
var iframe = document.createElement("iframe");
Must have a src element in MSIE HTTPs breaks aswell as absoute URLs
if (HTMLArea.is_ie)

iframe.src = _editor_url + editor.config.URIs.blank;

comment:2 Changed 13 years ago by mokhet

the update proposed by nico@… is already in htmlarea.js (can't find when it has been added, but it's in)

Is the problem still exist ? I have no trouble ( with Fx 1.0/1.5 and IE 6 ) loading up to 4 editors on same page (didn't tried more), and no trouble to use the example page.

If the problem still exist for someone ?

I think this ticket can be closed.

comment:3 Changed 13 years ago by mokhet

bump anyone ? Can we close this ticket or is there still an issue ?

comment:4 Changed 13 years ago by wymsy

I can't reproduce the problem either. I think we can close it. If someone still has an issue, they can reopen it.

comment:5 Changed 13 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

Aggreed, closing it. Reopen if it's a problem

Note: See TracTickets for help on using tickets.