Opened 13 years ago

Closed 9 years ago

#769 closed defect (fixed)

MS Code Cleaning Tool Bug - Certain code not cleansed

Reported by: jkronika Owned by: gogo
Priority: normal Milestone: 2.0
Component: Plugin_SuperClean Version: trunk
Severity: normal Keywords: microsoft word code cleaning source vml ssi
Cc:

Description

The following are example pieces of MSWord inserted code that is not removed by the MS Code Cleaning Tool, which I believe is part of the base Xinha editor. This was tested in r510.

<!--[if gte vml 1]><v:shapetype
 id="_x0000_t75" coordsize="21600,21600" o:spt="75" o:preferrelative="t"
 path="m@4@5l@4@11@9@11@9@5xe" filled="f" stroked="f">
 <v:stroke joinstyle="miter"/>
 <v:formulas>
  <v:f eqn="if lineDrawn pixelLineWidth 0"/>
  <v:f eqn="sum @0 1 0"/>
  <v:f eqn="sum 0 0 @1"/>
  <v:f eqn="prod @2 1 2"/>
  <v:f eqn="prod @3 21600 pixelWidth"/>
  <v:f eqn="prod @3 21600 pixelHeight"/>
  <v:f eqn="sum @0 0 1"/>
  <v:f eqn="prod @6 1 2"/>
  <v:f eqn="prod @7 21600 pixelWidth"/>
  <v:f eqn="sum @8 21600 0"/>
  <v:f eqn="prod @7 21600 pixelHeight"/>
  <v:f eqn="sum @10 21600 0"/>
 </v:formulas>
 <v:path o:extrusionok="f" gradientshapeok="t" o:connecttype="rect"/>
 <o:lock v:ext="edit" aspectratio="t"/>
</v:shapetype><v:shape id="_x0000_i1025" type="#_x0000_t75" style='width:16.5pt;
 height:16.5pt'>
 <v:imagedata src="file:///C:\DOCUME~1\ric\LOCALS~1\Temp\msohtml1\03\clip_image001.gif"
  o:title="tb_ileft_1"/>
</v:shape><![endif]--><!--[if !vml]--><!--[endif]-->
<!--[if gte vml 1]><v:shape
 id="_x0000_i1026" type="#_x0000_t75" style='width:16.5pt;height:16.5pt'>
 <v:imagedata src="file:///C:\DOCUME~1\ric\LOCALS~1\Temp\msohtml1\03\clip_image002.gif"
  o:title="tb_iright_1"/>
</v:shape><![endif]--><!--[if !vml]--><!--[endif]-->
<blockquote>
  <!--[if !supportLists]--> 
<!--[endif]-->From the pop-up window:<ul>

    <li>Browse for the image you wish to use.
Note: You will have access to the images uploaded to your site as well as the
images in the library. </li>
    <li><!--[if !supportLists]--> 
<!--[endif]-->Use the left-hand side of the window to
go to the section in which the image is located. Images will be displayed in
the right hand column. </li>
    <li><!--[if !supportLists]--> 
<!--[endif]-->Click on the image that you wish to
use. </li>
    <li><!--[if !supportLists]--> 
<!--[endif]-->The pop-up window will close and the image you
selected will appear in the WYSIWYG Editor.</li>
    <li><!--[if !supportLists]--> 

<!--[endif]-->You can change the placement of the image by
clicking and dragging it. Note: Though you can resize an image by dragging on
its selection bars, this is not recommended, as the quality of the resized
image is likely to be poor. &nbsp;&nbsp;</li>
  </ul>
</blockquote>

<ol start="6" style="margin-top: 0in;" type="1">
<li style="color: black;">
<!--[endif]-->

Aside from some line breaks that were removed to reduce the vertical space for these blocks, this is precisely the output of Xinha. This was initially noticed in r179, and persisted after an update.

Change History (3)

comment:1 Changed 12 years ago by gogo

  • Component changed from Xinha Core to Plugin_SuperClean
  • Milestone set to 2.0
  • Priority changed from high to normal
  • Type changed from defect to enhancement

comment:2 Changed 11 years ago by guest

  • Type changed from enhancement to defect

We have a similar problem, specifically relating to code snippets of the following form:

<!--[if supportLineBreakNewLine]-->
<!--[endif]-->

The problem is that, ironically, although they are invisible in Firefox, when viewed as HTML, under IE, for some reason they are displayed to the user as visible tags.

This problem shows up in the Roller blogger software, which uses Xinha for entry editing. This seems to be a defect rather than an enhancement request to me, as the Word code that is allowed through actually breaks the IE rendering.

I checked the latest nightly build, and the problem persists there.

comment:3 Changed 9 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

I see code in SuperClean?'s filter to remove comments. betting this is already done.

Note: See TracTickets for help on using tickets.