Opened 9 years ago

Closed 8 years ago

#766 closed defect (fixed)

R496 crashes IE6

Reported by: buz Owned by: gogo
Priority: highest Milestone: Version 1.0
Component: Xinha Core Version:
Severity: blocker Keywords: ie6 broken crash
Cc:

Description

It seems to me that standard full_example.html example currently crashes IE6 (freezes, then at some point I can only kill the whole browser) quite reliably.

To reproduce: point IE6 to full_example.html

Change History (17)

comment:1 Changed 9 years ago by michael

I couldn't get R511 (or R512) to work at all in IE6 (lost a mornings work trying to work out if I'd changed something) though it worked fine on Firefox 1.5. Reverted back to R490 (because that was the previous revision I'd checked out) and it worked again.

comment:2 Changed 8 years ago by buz

I can confirm that 512 crashes IE as well.

comment:3 Changed 8 years ago by mharrisonline

  • Milestone set to Version 1.0

Ditto.

comment:4 Changed 8 years ago by wymsy

Is it broken everywhere, or just in the examples? If it's just the examples, the culprit has to be changeset:511. Not sure, but I'm guessing it's the '.' after 'DIRECTORY_SEPARATOR'.

comment:5 Changed 8 years ago by buz

Broken everywhere for all I know as it doesn't work on my version that integrates into eZPublish, either.

comment:6 Changed 8 years ago by buz

It would seem to me that 495 was the last working version in IE6. So the changeset 496 is probably at fault.

comment:7 Changed 8 years ago by mharrisonline

It works for me when the download is on my desktop, but once I put it on a Web server and access it that way, it never finishes initiating.

comment:8 Changed 8 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

changeset:513 - I don't know if this truely solves the problem, but it at least works for me now. I'm at a loss as to why it fixes it, or even what the problem is to start with. If anybody still has this problem after 513 please reopen.

comment:9 Changed 8 years ago by GazElms

I'm still not sure that this is a good fix. I think the reason it occurs is because this piece of code in initSize() :

HTMLArea.addDom0Event(window, 'resize', function(e) { editor.sizeEditor(); });

Calls the sizeEditor() function every time the window is resized. It might be that when the panels are resized with this code :

  // (re)size the left and right panels so they are equal the editor height
  for(var i = 0; i < this._panels.left.panels.length; i++)
  {
    this._panels.left.panels[i].style.height = this._iframe.style.height;
  }

  for(var i = 0; i < this._panels.right.panels.length; i++)
  {
    this._panels.right.panels[i].style.height = this._iframe.style.height;
  }


this is triggering the event and it continues forever. When I was debugging this problem the sizeEditor() function was repeatedly invoked. Will download latest version and see how I get on.

comment:10 Changed 8 years ago by buz

R513 doesn't seem to help my IE very much.

It still freezes.

comment:11 Changed 8 years ago by GazElms

  • Resolution fixed deleted
  • Status changed from closed to reopened

513 still has the same problem on my machine. Any ideas on this one?

If you follow the link below in internet explorer it freezes. This is due to the css, not looked into it properly but the stylist plugin inserts css, perhaps this might be the cause?

[www.meyerweb.com/eric/css/tests/ie-freeze.html Internet Explorer Freeze]

comment:12 Changed 8 years ago by gn@…

There are some indications, that we have an timing problem here,
maybe similar to:
http://www.formvista.com/otherprojects/areaedit/faq.html#FAQ7

I had xinha throwing arbitrary javascript error messages from
varying line numbers, while connecting via WLAN. The same page
from the same machine and exactly the same browser instance works
without problems via LAN

comment:13 Changed 8 years ago by mharrisonline

If I comment out the first block of changed code, Xinha starts perfectly for me on a server in IE.

I commented out the new lines from 1911 to 1923, and everything works fine:

  this._iframe.style.height = edcellheight + 'px';  
//  this._framework.rp_cell.style.height = edcellheight + 'px';
//  this._framework.lp_cell.style.height = edcellheight + 'px';
  
  // (re)size the left and right panels so they are equal the editor height
//  for(var i = 0; i < this._panels.left.panels.length; i++)
//  {
//    this._panels.left.panels[i].style.height = this._iframe.style.height;
//  }
  
//  for(var i = 0; i < this._panels.right.panels.length; i++)
//  {
 //   this._panels.right.panels[i].style.height = this._iframe.style.height;
//  }  
  
  var edcellwidth = width;

Does this fix it for anyone else?

comment:14 Changed 8 years ago by mharrisonline

Does anyone know if commenting out those lines will cause anything in Xinha to break?

comment:15 Changed 8 years ago by mharrisonline

  • Summary changed from R511 crashes IE6 to R496 crashes IE6

It looks like the problem was Revision 496, which should be rolled back or fixed, so that Xinha will once again work from a server in IE.

comment:16 Changed 8 years ago by wymsy

I commented those lines out in changeset 519. We should probably also reopen ticket 543, which R496 was supposed to fix.

comment:17 Changed 8 years ago by mharrisonline

  • Resolution set to fixed
  • Status changed from reopened to closed

Well, that fixed this ticket. I'm going to close it for now. Thanks, wymsy.

Note: See TracTickets for help on using tickets.