Opened 14 years ago

Closed 14 years ago

#742 closed defect (invalid)

Problem with character "&" translate by "&" when using popup web link

Reported by: frederic.gaveriaux@… Owned by: gogo
Priority: high Milestone:
Component: Plugin_Linker Version:
Severity: blocker Keywords: link
Cc:

Description

When I use the popup web link, and I write the URL with a link which contains a character "&", this link for example:

http://www.test.fr/page_label&action=creation

is translated by:

<a href="http://www.test.fr/page_label&amp;action=creation">test</a>

So this link doesn't work.
Is there a solution to translate the link containing a "&" accurately?

Change History (3)

comment:1 Changed 14 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

This is actually the correct behaviour, because in (X?)HTML the & is special reserved character that has to be written as &amp;. And it works, no problem.
But your URL is wrong, you have to initiate a query string sequence by a ? first, so it should be
http://www.test.fr/page_label?action=creation&amp;anotherparametert=thisway

comment:2 Changed 14 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I understand your answer but more accurately the URL we want to enter is:

http://www.superu-lodeve.com/portailu/appmanager/PortalPortaillU/local?_nfpb=true&_pageLabel=pg_d_sysu_accueil_inscription&pagedepart=pg_d_sysu_accueil_accueil&action=creation

So there is a "?" but the problem is still here, even if we put the URL like this:

http://www.superu-lodeve.com/portailu/appmanager/PortalPortaillU/local?_nfpb=true&amp;_pageLabel=pg_d_sysu_accueil_inscription&amp;pagedepart=pg_d_sysu_accueil_accueil&amp;action=creation

That's why it seems that the "?" doesn't avoid the problem.

Moreover the link doesn't work even if the & is logically translate in HTML code by &amp;,then the "&" from the word &amp; is translate and we've got &amp;amp;.
Can you see another solution?
Thank you.

comment:3 Changed 14 years ago by ray

  • Resolution set to invalid
  • Status changed from reopened to closed

This is not a bug. It is perfectly correct, because & is forbidden in the href attribute.
I'm sorry it doesn't work, but could ask in the forum if anybody can help you.

Only for demonstrational purposes: http://raimundmeyer.de/xinha/ampersand_href.php

Note: See TracTickets for help on using tickets.