Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#723 closed defect (invalid)

Forms/FormOperations: Textarea tag inside Xinha corrupts WYSIWYG panel

Reported by: villar Owned by: akaEdge
Priority: normal Milestone:
Component: Documentation Version:
Severity: normal Keywords:
Cc:

Description

Hi,

There's a bug in the panel whereby using a textarea inside the xinha textarea corrupts the WYSIWYG frame.

Here's a screenshot (if I can upload that is)

http://redshift.server101.com/fun/screengrab123.gif

1: The starting page.
2: create a form and add a textarea inside it.

--- Save your work so that it is stored on the db ---

3: upon retrieving the file, this is what you get.

Any ideas?

Change History (2)

comment:1 Changed 12 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug, but the logical behaviour of the HTML parser. The rules of HTML dictate that inside textareas only PCDATA is allowed, that is no tags. So if the parser finds a closing textarea tag it closes the textarea, resulting in what you have.
Solution you have to entitize the <'s and >'s and (& and ") in your HTML inside the textarea, e.g. in PHP with htmlspecialchars().

I will close this ticket. If I didn't get your problem, please reopen.

comment:2 Changed 12 years ago by villar

Thanks for the tip :)

worked like a charm... amazing how I didn't think of it in the first place - guess I'm not as good as I think I am :P

Note: See TracTickets for help on using tickets.