Opened 9 years ago

Closed 8 years ago

#716 closed defect (wontfix)

Plugins' buttons : Position defined only through xinha_config.toolbar, please !

Reported by: sgougeon Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

After hours of parametrizing xinha, I have found quite
annoying to have to turn into comment any
cfg.addToolbarElement(); line into the respective plugin.js
for almost any plugins that I have declared. Indeed, it is
much more pleasant to decide oneself through the
xinha_config.toolbar the proper gathering into groups
and order of groups and inside groups of buttons, instead
of getting predefined groups & sorting orders.

So, it would be really kind to let the user explicitly and fully
defining the xinha_config.toolbar parameter, without calling
cfg.addToolbarElement();

By the way, I failed using such a strategy for some specific
plugins, noticeably the "fullscreen" one. No success in finding why.

sgougeon (a) univ-lemans.fr (Sam)

Change History (1)

comment:1 Changed 8 years ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

Not a bug. Plugins add thier own buttons because most people don't want to work out what buttons a plugin needs. You can replace the toolbar after plugins are registered with your own design if you wish.

Note: See TracTickets for help on using tickets.