Opened 9 years ago

Closed 8 years ago

#700 closed defect (fixed)

In IE half of the interface buttons don't show - in Firefox they do

Reported by: Dick Mansfield Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version: trunk
Severity: major Keywords: buttons IE OpenWebMail
Cc:

Description

I am trying to incorporate Xinha in my copy of OpenWebMail? instead of the default (and near-dead...) HtmlArea?.
In Firefox all works fine, but in IE about half of the interface buttons don't show.
In fact they're there: when you know where they are supposed to be and hover over them with the mouse, a blank square shows, the button's title pop-up shows and when you press the button does its job. But if you don't hover over it with the mouse, there is no sign of the buttons at all.
Any ideas?

Change History (2)

comment:1 Changed 8 years ago by Dick Mansfield

Sorry I couldn't be more specific in last post. Since then I discovered the cause of the bug.
The problem only occurs in RTL pages (Arabic,Hebrew) i.e. when Xinha is called in a html page that has dir=rtl in the head section.
The cause is the ed_buttons_main.gif matrix that is used by default in htmlarea.js.

When in an RTL page, IE (but not Firefox) tries to swap (read RTL) the ed_buttons_main.gif as well, and then tries to use it, which of cause fails. Therefore most buttons don't have faces, except for the ones that don't use ed_buttons_main.gif (a few standard ones and most plugin buttons).
I solved the problem manually by painstakingly replacing all instances of ed_button_main.gif with their separate buttons that appears (fortunately...) in /images. Also the "fullscreen" plugin uses ed_buttons_main.gif and had to be changed.
The ed_buttons_main.gif thing is a cute idea, but for RTL users with IE it is a pain.
In any case, dear Xinha developers, in light of all this, maybe you would consider to do the following:

  1. don't delete the separate button icons in /images in future versions. without them we would be lost all together...
  2. please post a notice as to the above mentioned problem somewhere on the documentation, so that RTL people won't have to guess what's going wrong.
  3. If possible, supply for those in need (...) a separate download of a ready-made version of Xinha that doesn't use ed_buttons_main.gif and has the buttons gifs already named separately.

Thanks for your great work !!
Dick

comment:2 Changed 8 years ago by gocher

  • Resolution set to fixed
  • Status changed from new to closed

To fix that problem you only have to set the container div of the image/button to lefttoright

      el.style.direction = "ltr";

look at #510

Changeset 483

Note: See TracTickets for help on using tickets.