Opened 12 years ago

Closed 12 years ago

#698 closed defect (invalid)

imagemanager not working with mod_rewrite?

Reported by: Jabrwock Owned by: yermol
Priority: normal Milestone:
Component: Plugin_ImageManager Version:
Severity: normal Keywords: installation
Cc:

Description

I'm using xinha plugged into serendipity (http://www.s9y.org), and while xinha can find my images directory (/s9y/images/), it tries to do a relative url to the images (images/), so when a page is displayed with a custom url through apache's mod_rewrite, the image url is no longer valid.

How do I configure xinha to use the absolute path (/s9y/images/) (without inserting the hostname) so that mod_rewrite can direct the <img> tag to the proper location?

Change History (1)

comment:1 Changed 12 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

there are two config variables in the ImageManager config.inc:
$IMConfigimages_dir? = '/full/path/to/images/';
$IMConfigimages_url? = '/url/to/images/';
The second one is the the one that is prefixed to the filename. I think you can set it to anything you need.
Anyway, this is not a bug, ask it in the forum.

Note: See TracTickets for help on using tickets.