Opened 8 years ago

Closed 8 years ago

#697 closed defect (invalid)

Can not install xinha

Reported by: anonymous Owned by: anonymous
Priority: high Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: Installation
Cc:

Description

Hello,
I want to install Xinha-editor. Take the xinha-nightly.zip from today, unpack it on localhost/backend/xinha. Than I wrote a little htmlscript, only html-head-body, make the steps in Xinha newbie guide. the editor opens, but the menubar ist disabled. Firefox firebug write: uncaught exception: [Exception... "Unexpected error" nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: http://localhost/cms2.6/backend/xinha/htmlarea.js :: anonymous :: line 4992" data: no].
At first click comes:
[Exception... "'Die Erlaubnis für das Lesen der Eigenschaft CSSStyleDeclaration.cssText wurde verweigert' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no] (in english:No rights for read the propertie CSS..
And after every klick in textarea come this error again:'Die Erlaubnis für das Lesen der Eigenschaft CSSStyleDeclaration.cssText wurde verweigert'

What's to do ?

Best wishes!

Andreas

Attachments (1)

Editortest.php (4.8 KB) - added by anonymous 8 years ago.
my test

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by anonymous

my test

comment:1 Changed 8 years ago by anonymous

  • Owner changed from gogo to anonymous
  • Status changed from new to assigned

comment:2 Changed 8 years ago by mobi@…

Check your $_SERVERSERVER_NAME?. It may contain 'www' prefix and document.location.href doesn't. I've noticed this error in my implementation. If you write 'www.yoursite.com' as address in your browser it works fine but 'yoursite.com' makes error.

comment:3 Changed 8 years ago by gogo

  • Resolution set to invalid
  • Status changed from assigned to closed

Sounds like a permissions problem, not a bug anyway, please ask in the forums for installation advice.

Note: See TracTickets for help on using tickets.