Opened 14 years ago

Closed 13 years ago

#688 closed defect (fixed)

html corruption with <p> tags

Reported by: akaEdge Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: html corruption
Cc:

Description

This problem has been duplicated on Firefox 1.5.0.1 and IE 6.0. - with the latest nightly version as per 24/02/2006

If I type <p>some test text</p> into the xinha-area (<p> can be replaced by <h1> etc - but not <u> or other inline formatting) when it is in html editing mode, and then I switch back to WYSIWYG mode and then back to htmlmode I see that the <p>some test text</p> has had a line break (and space in IE) inserted before it.

If this is then submitted (with line break and space) that is the data that ends up in my database.

But then when I re-populate my xinha-area with this data the linebreak is replaced by a <br> tag and the space by &nbsp; and another linebreak and space are there. This means I keep submitting the form the data keeps moving down and down!

I have turned off all outer style sheets just in case any padding etc was being interpreted as a line break. Still no luck. I thought it might have something to do with the fact that there looks like there is a line break there in the WYSIWYG mode (there seems to be around a 10px padding top and left)

I notice there was another ticket about html curruption - it didn't quite look the same though - and that fix didn't seem to have any effect.

Here is an example page if you want to see - you can submit if you want to.
http://www.wildcatsfc.com/news/test_edit_article.asp?news_article_ref=3EABC7DBFDA643AD89084AF63FF0FAB9

Change History (4)

comment:1 Changed 13 years ago by gogo

  • Component changed from Xinha Core to Plugin_GetHtml
  • Owner changed from gogo to wymsy
  • Priority changed from highest to high
  • Severity changed from critical to normal

This appears to be a problem in GetHtml?

comment:2 Changed 13 years ago by wymsy

I can't reproduce this in Firefox either in the xinha examples or my own installation (using GetHtml?), or akaEdge's example page (which is *not* using GetHtml?). In IE6 I can't get the xinha examples to load (IE crashes during the page load). My installation does not have the problem, but akaEdge's example does insert the line break and space. Submitting his form threw an error, so couldn't test the conversion of line breaks to br tags, but I suspect that is happening somewhere in the process of saving to the database and retrieving it again, not in xinha.

comment:3 Changed 13 years ago by wymsy

  • Component changed from Plugin_GetHtml to Xinha Core
  • Owner changed from wymsy to gogo

The only plugin in the submitter's example is FullScreen?, so this is not a gethtml problem. I have done some more testing and still cannot reproduce the problem with the added br tags. Can anyone verify that this happens in xinha, or should we conclude that it is a server-side problem and close as works-for-me?

comment:4 Changed 13 years ago by mokhet

  • Resolution set to fixed
  • Status changed from new to closed

I confirm the "problem" with changeset:377 but i can't reproduce it in changeset:548

I'm closing it now.

Note: See TracTickets for help on using tickets.