Opened 13 years ago

Closed 13 years ago

#687 closed defect (invalid)

Incorrect image links in InsertSmiley

Reported by: jim.cartlidge@… Owned by: akaEdge
Priority: normal Milestone:
Component: Documentation Version:
Severity: major Keywords:
Cc:

Description

IIS appends the current script root to links in InsertSmiley? if a virtual root is supplied in the _editor_url variable.

eg. My dir structure
c:\websites\phproot\admin\scripts\xinha\....
_editor_url = 'scripts/xinha/';

everything works as normal except ie puts image locations as

http://localhost/phproot/admin/scripts/xinha/plugins/InsertSmiley/popups/scripts/xinha/plugins/InsertSmiley/smileys/0014.gif

even though

<img alt="Smiley" src="scripts/xinha/plugins/InsertSmiley/smileys/0014.gif" /> is returned when the image is clicked upon.

changing line 41 of insertSmileys.html to

trow.insertCell((i - 1) % 4).innerHTML = "<a href=\"javascript:onOK('" + inum + "')\"><img style=\"border: 0px;\" alt=\"Smiley " + i + "\" src=\"../smileys/" + inum + ".gif\" />";

solves the problem by using virtual paths.

Attachments (1)

insert-smiley.js (1.7 KB) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by anonymous

comment:1 Changed 13 years ago by gocher

you have to use

_editor_url = '/scripts/xinha/';

not

_editor_url = 'scripts/xinha/';

and it works!

comment:2 Changed 13 years ago by gogo

  • Resolution set to invalid
  • Status changed from new to closed

Closing then as not a bug (as gocher says, best to use an absolute editor url).

Note: See TracTickets for help on using tickets.