Opened 12 years ago

Last modified 8 years ago

#684 new defect

SpellChecker messing with my images

Reported by: anonymous Owned by: gogo
Priority: normal Milestone:
Component: Plugin_SpellChecker Version:
Severity: major Keywords: images, &nbsp
Cc:

Description

I got the spellchecker installed and working however there are some quirks I don't know how to fix.

1) It finds the forced space &nbsp to be a misspelled word. And I cannot add it to the dictionary

2) Image files get very messed up by, for some reason, automatically changing <img to <span class= then it starts changng the quotes and such.

Change History (4)

comment:1 Changed 12 years ago by gogo

Which version are you using? You MUST use the PHP version, and I suggest using the pre-compiled aspell available in the SpellChecker wiki page.

comment:2 Changed 12 years ago by anonymous

comment:3 Changed 12 years ago by guest

I've seen this too - for images, not &nbsp;
Release: Trunk (Wed, 29 Mar 2006 17:39:53 +1200)
Revision: 484

It appears to spell check the alt tag of images and if it doesn't recognise a word then inserts a <span> into the img tag which breaks the img tag.

Anyway, I have written a fix for my app which works by splitting out all the html tags and content before sending it to aspell. The tags are reinserted afterwards. It's not great, but if you want to see it them I'm on the forums under steveo125.

comment:4 Changed 8 years ago by gogo

  • Severity changed from normal to major

This is old, but I saw the problem recently, so keeping it active. I think we need a better spell checker written though.

Note: See TracTickets for help on using tickets.