Opened 13 years ago

Closed 12 years ago

#643 closed defect (fixed)

WYSIWYG edittor is not working under new Mozialla Firefox

Reported by: w.schuette@… Owned by: akaEdge
Priority: normal Milestone:
Component: Documentation Version:
Severity: normal Keywords:
Cc:

Description

Hello,

the WYSWWYG editor is not longer working with new Mozialla Firefox verison 1.5. Version 1.0.4 is working well.

Any idea?

Thanks

Change History (3)

comment:1 Changed 13 years ago by gogo

What version of Xinha (version is written in the first few lines of htmlarea.js).

comment:2 Changed 13 years ago by benDOTsimkinsATintsoftDOT.ch

If you want to correct the version that you have installed and not go through the pain of installing a new version, you need to go to line 4315 (or thereabouts), and replace the following lines:

  // check for array objects
  if (obj.constructor.toString().indexOf("function Array(") == 1) {
    newObj = obj.constructor();
  }

  // check for function objects (as usual, IE is fucked up)
  if (obj.constructor.toString().indexOf("function Function(") == 1) {

as follows :

  // check for array objects
  if (obj.constructor.toString().match( /\s*function Array\(/ )) {
    newObj = obj.constructor();
  }

  // check for function objects (as usual, IE is fucked up)
  if (obj.constructor.toString().match( /\s*function Function\(/ )) {

Note: I found this correction somewhere on the net shortly after the release of Firefox 1.5, but I can't remember where. This may be corrected in the latest version of Xinha, I haven't checked. As I recall it has to do with Firefox inserting an extra line break in front of the 'function' string when you toString() as function.

comment:3 Changed 12 years ago by mokhet

  • Resolution set to fixed
  • Status changed from new to closed

The correction is already in trunk and the bug is fixed since a long time ago. I'm closing this ticket now, if the issue is still here please reopen and explain. Thanks.

Note: See TracTickets for help on using tickets.