Opened 14 years ago

Closed 13 years ago

#630 closed defect (fixed)

Scrolling problem IE 6

Reported by: Alex Mooij Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version:
Severity: major Keywords: scroll ie shift
Cc:

Description

When the text inside the editor is too long and scrollbars appear things go wrong. When for example my page is 10 times longer than the workspace of Xinha and I scroll to the middle of the page and place my cursor somewhere in the text the page shifts to another position. Most of the time the cursor can be found at the last line visible in the editor, but at the end of the page it shifts out of sight. This keeps on happening when you apply a function on a piece of text which leaves you with searching for the location where you placed your cursor all the time. Because of this it is unworkable. This is only in IE, I use version 6.0.2900.2180 on XP Pro SP2.

By the way: the form where the textarea is in is inside a div. These are the divs props.

=======================================
color: black;
font-size: 9px;
font-family: verdana, arial, sans-serif;
background-color: white;
position: fixed;
z-index: 1;
width: 720px;
overflow: auto;
visibility: visible
=======================================

Any suggestions?

Regards,
Alex Mooij

Change History (4)

comment:1 Changed 14 years ago by alex.mooij@…

I tested it without the divs enclosing it but it does not work either. Also I found a ticket resembling my problem however it is set to the plugin ListType?. I don't use ListType? so I think it is a core problem. It seems xinha calculates where you place your cursor and IE want to scroll the page to the top whereafter xinha tries to scroll it back to the place of the cursor. Here it goes wrong.

I also found out that when you simply click to place the cursor it usually works, when you select text it immediatly shifts and mostly leaves you at the middle of the page. I looks like it cannot calculate the position of the cursor when selecting (dragging and double-clicking just the same) and just leaves you at the middle of the page.

comment:2 Changed 14 years ago by ghis

  • Priority changed from normal to high

I have the same scrolling problem with IE and the "FormOperations?" plugin.

The bug is reproducible on the example page :
just add the "FormOperations?" plugin, add some text to have a scrollbar, and try scrolling and clicking somewhere down in the text...
Wrap ! The cursor is moved on the beginning of the page, whatever you do.

comment:3 Changed 14 years ago by anonymous

HI I have this problem as well? has anyone found a hack?

comment:4 Changed 13 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

I've committed what I think is a fix in changeset:505 - will close this, if it still occurs please reopen.

Note: See TracTickets for help on using tickets.