Opened 14 years ago

Closed 13 years ago

#623 closed defect (duplicate)

Editor doesn't load in IE6.0.2900.2180.xpsp_sp2_gdr.050301-1519IS

Reported by: anonymous Owned by: gogo
Priority: highest Milestone:
Component: Xinha Core Version:
Severity: critical Keywords: IE6
Cc:

Description

The editor from the examples page simply didn't load at all.

I received two textarea boxes and nothing else. View Source show that the javascript has loaded and the instances are there; just no editor.

Change History (10)

comment:1 Changed 14 years ago by anonymous

  • Resolution set to worksforme
  • Status changed from new to closed

comment:2 Changed 14 years ago by gogo

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reopening, an anonymous user saying it works without further comment doesn't exactly satisfy my curiosity on this one.

comment:3 Changed 14 years ago by mokhet

anyone with XP sp2 and IE6 can confirm this bug ? I have no access to XP and cant perform any test.

comment:4 Changed 13 years ago by CzarWeb

  • Priority changed from normal to highest

I am experiencing the very same problem in an application I am currently developing. Everything works great until the user (in IE only) tries to edit or add a page (loading Xinha).

I checked my IE build, and sure enough:
'Version: 6.0.2900.2180.xpsp_sp2_gdr.050301-1519'

I get an alert popup that says:
[message]
Internet Explorer cannot open the site http:// ... blah blah ...

Operation aborted
message

What is odd about this one is that it was working before - both in Firefox 1.5 and IE 6.0. I have not updated anything - the Xinha code, or either browsers. Automatic updates are turned on, so maybe IE was updated automatically? As it is not, this pretty much renders my whole application useless in IE, because none of the page will load, and it goes to the internal IE 'Cannot find server' page.

comment:5 Changed 13 years ago by mharrisonline

I am running XP2 sp2 home and the exact same version of IE, and have no trouble with Xinha loading. I wonder if it could be caused by a change in the user's connectivity through a firewall or proxy server; or if their security settings were changed by a network administrator.

comment:6 Changed 13 years ago by anonymous

I'm having the exact same problem with IE6.0.2900.2180... It runs perfectly on Firefox but does not work at all on IE with the symptoms as desribed earlier in th ticket, with the alert popup.

comment:7 Changed 13 years ago by anonymous

Hi - just checking the tiket and found in Ticket #294 that Xinha and HTMLArea running in IE have a problem when the doc has a BASE element defined in the head. I removed it and my page is working now.

comment:8 Changed 13 years ago by benDOTsimkinsATintsoftDOT.ch

Not directly related, but just for future reference. From what I have observed, you can't count on just the IE version to completely define behaviour - I have had bugs in IE that appear (on the same computer) with Windows XP default theme, but not with Windows Classic theme...

comment:9 Changed 13 years ago by CzarWeb

Yep, it was my '<base>' tag. I added a '</base>' to the end of it instead of the self-closing '/>' and it works in IE now. Thanks for pulling up that ticket... what a strange bug... Anyways, at least now I won't have to switch to TinyMCE or FCK.

comment:10 Changed 13 years ago by gogo

  • Resolution set to duplicate
  • Status changed from reopened to closed

Dup of #294 then. Not sure if #294 will be fixable though, sounds like a bug in IE

Note: See TracTickets for help on using tickets.