Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#608 closed defect (invalid)

I am getting a javascript error when using Safari v2.02 build 416.12 on Mac OS X.4.3

Reported by: rianhall1@… Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc:

Description

I am experiment with Drupal version 4.6 and have added the approp. javascript code in my templates header. However, I am getting this error whenever I load my pages

Mozilla < 1.3 Beta is not supported!
I'll try, though, but it might not work.

I did a search on the error mesage and found this code in the htmlarea.js file:

FIXME!!! this should return false for IE < 5.5
HTMLArea.checkSupportedBrowser = function() {

if (HTMLArea.is_gecko) {

if (navigator.productSub < 20021201) {

alert("You need at least Mozilla-1.3 Alpha.\n" +

"Sorry, your Gecko is not supported.");

return false;

}
if (navigator.productSub < 20030210) {

alert("Mozilla < 1.3 Beta is not supported!\n" +

"I'll try, though, but it might not work.");

}

}

return HTMLArea.is_gecko
HTMLArea.is_ie;

};

It looks like the htmlarea.js is thinking I am running a gecko based browser when it's not. I believe this code needs to be updated to reflect khtml based browsers as well as gecko.

Change History (3)

comment:1 Changed 8 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

We do not support Safari at this time.

comment:2 Changed 8 years ago by gogo

anonymous = gogo, forgot to login :-)

comment:3 Changed 8 years ago by anonymous

yrgtesgrg

Note: See TracTickets for help on using tickets.