Opened 14 years ago

Closed 14 years ago

#585 closed defect (invalid)

How to disable a Xinhas Textarea

Reported by: tribeiro@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: Enable disable function
Cc:

Description

Hi,

What I’m trying to do is this:
When the page is loaded, I want the editor and the textareato be disabled.
When the user checks a checkbox, I want to turn it to enabled, and if uncheck’s it again I want to turn it disable again.
Is this possible?
I tried with the following, but with no result

function SetState?(obj_checkbox, obj_textarea)

{ if(obj_checkbox.checked)

{ obj_textarea.disabled = true;
}
else
{ obj_textarea.disabled = false;
}

}


<input type="checkbox" onclick="SetState?(this,this.form.txtConteudo)">
<TEXTAREA id='txtConteudo' NAME='txtConteudo'>

Best regards,

Tiago Ribeiro

Change History (1)

comment:1 Changed 14 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

That won't work, you need to manipulate the generated Xinha not the textarea.

Also not a bug, so take it to the forum thanks.

Note: See TracTickets for help on using tickets.