Opened 14 years ago

Closed 14 years ago

#575 closed defect (invalid)

surroundHTML changes case of <span> parameters

Reported by: Random Bits Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version:
Severity: critical Keywords:
Cc:

Description

When using .surroundHTML('<span onClick=("doSomething();")>','</span>');

the resulting insert has all the paramter names set to lower case:
<span onclick=("doSomething();")>

which of course makes onClick not work.

Change History (1)

comment:1 Changed 14 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

HTML is caseless. xhtml is lowercase. This is not a bug. Your onclick attribute format is horribly non html, lose the surrounding parenthesis.

Note: See TracTickets for help on using tickets.