Opened 13 years ago

Closed 12 years ago

#549 closed defect (invalid)

form cannot be sent in IE, but in Firefox

Reported by: anonymous Owned by: gogo
Priority: high Milestone: Version 1.0
Component: Xinha Core Version:
Severity: critical Keywords: sending form IE
Cc:

Description

Hallo,

when the texts inserted into the editor becomes to complex, the form cannot be sent in the Internet Explorer (Version 6.0.2900.2180.xsp_sp2_gdr.050301-1519).

If I use the script debugging functionality of the IE ("Halt on the next action") and continue the javacript actions with F5 it finally stops with an error saying that there is a wrong syntax within htmlfile.

The form cannot be sent independently wheter I send it with a submit-button or from a javascript-function, using document.<formname>.onsubmit() and document.<formname>.submit() afterwards. In the latter case the onsubmit() still works, but submit() creates the error.

When I send the same form with Firefox I have no problems.

An example for an editor-content which cannot be sent is the following:

<p>
    <table style="FLOAT: none; BACKGROUND-IMAGE: none; VERTICAL-ALIGN: top; BORDER-TOP-STYLE: none; BORDER-RIGHT-STYLE: none; BORDER-LEFT-STYLE: none; TEXT-ALIGN: left; BORDER-BOTTOM-STYLE: none" cellspacing="1" cellpadding="1" rules="none" border="0" frame="void">
      <tbody>
        <tr>
          <td><img src="http://localhost/tajo-coaching/Webseite/images/bf4.gif" /><br /></td>
          <td><br /></td>
          <td class="haupttextfett">Regulation von Leistungsstress<br /></td>
        </tr>
      </tbody>
    </table>
  </p>
  <p class="haupttext">Effektive Stressregulierung bei Spannungsfeldern im Team oder mit Kunden, „Rampenlicht-Stress“ oder „Nackenschlägen“ auf dem Weg zum Ziel sowie bei körperlichem Stress wie Schlafmangel. Sie fühlen sich durch die rasche Stabilisierung Ihrer inneren Balance schnell wieder energievoll, innerlich ruhig und konfliktstark.</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>
    <table style="FLOAT: none; BACKGROUND-IMAGE: none; VERTICAL-ALIGN: top; BORDER-TOP-STYLE: none; BORDER-RIGHT-STYLE: none; BORDER-LEFT-STYLE: none; TEXT-ALIGN: left; BORDER-BOTTOM-STYLE: none" cellspacing="1" cellpadding="1" rules="none" border="0" frame="void">
      <tbody>
        <tr>
          <td><img style="BORDER-RIGHT: 0px solid; PADDING-RIGHT: 0px; BORDER-TOP: 0px solid; PADDING-LEFT: 0px; PADDING-BOTTOM: 0px; MARGIN: 0px; BORDER-LEFT: 0px solid; PADDING-TOP: 0px; BORDER-BOTTOM: 0px solid" height="50" alt="bf1.gif" src="http://localhost/tajo-coaching/Webseite/images/bf1.gif" width="50" /><br /></td>
          <td><br /></td>
          <td class="haupttextfett">Ressource - Coaching</td>
        </tr>
      </tbody>
    </table>
  </p>
  <p class="haupttextfett">&nbsp;</p>
  <p class="haupttext">Hier geht es um alle Themen, die mit Erfolg und Lebenszielen zu tun haben. Für die Arbeit mit dem Selbstbewusstsein, dem Selbstbild, Selbst-motivation, Stärkung des „inneren Teams”, Ziel-visualisierung und für die mentale Vorbereitung auf die Spitzenleistung, wie beispielsweise einen öffentlichen Auftritt, eignet sich diese Form hervorragend.</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>
    <table style="FLOAT: none; BACKGROUND-IMAGE: none; VERTICAL-ALIGN: top; BORDER-TOP-STYLE: none; BORDER-RIGHT-STYLE: none; BORDER-LEFT-STYLE: none; TEXT-ALIGN: left; BORDER-BOTTOM-STYLE: none" cellspacing="1" cellpadding="1" rules="none" border="0" frame="void">
      <tbody>
        <tr>
          <td><img style="BORDER-RIGHT: 0px solid; PADDING-RIGHT: 0px; BORDER-TOP: 0px solid; PADDING-LEFT: 0px; PADDING-BOTTOM: 0px; MARGIN: 0px; BORDER-LEFT: 0px solid; PADDING-TOP: 0px; BORDER-BOTTOM: 0px solid" height="50" alt="bf2.gif" src="http://localhost/tajo-coaching/Webseite/images/bf2.gif" width="50" /><br /></td>
          <td><br /></td>
          <td class="haupttextfett">Belief - Coaching</td>
        </tr>
      </tbody>
    </table>
  </p>
  <p class="haupttext">Leistungseinschränkende Glaubenssätze werden bewusst gemacht und in Ressource-Beliefs verwandelt. Eine besondere Bedeutung hat das Auffinden von „Euphorie-Fallen” im Beliefsystem, die den Irrtum fördern, sich für „unkaputtbar” zu halten. Das Ziel ist eine emotional stabile Beliefbasis, die auch anspruchsvollen mentalen Belastungen stand hält.</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>
    <table style="FLOAT: none; BACKGROUND-IMAGE: none; VERTICAL-ALIGN: top; BORDER-TOP-STYLE: none; BORDER-RIGHT-STYLE: none; BORDER-LEFT-STYLE: none; TEXT-ALIGN: left; BORDER-BOTTOM-STYLE: none" cellspacing="1" cellpadding="1" rules="none" border="0" frame="void">
      <tbody>
        <tr>
          <td><img style="BORDER-RIGHT: 0px solid; PADDING-RIGHT: 0px; BORDER-TOP: 0px solid; PADDING-LEFT: 0px; PADDING-BOTTOM: 0px; MARGIN: 0px; BORDER-LEFT: 0px solid; PADDING-TOP: 0px; BORDER-BOTTOM: 0px solid" height="50" alt="bf3.gif" src="http://localhost/tajo-coaching/Webseite/images/bf3.gif" width="50" /><br /></td>
          <td><br /></td>
          <td class="haupttextfett">Die wingwave<sup>®</sup>-CD</td>
        </tr>
      </tbody>
    </table>
  </p>
  <p class="haupttextfett">&nbsp;</p>
  <p class="haupttext">Für die selbständige Weiterführung des <strong>w</strong>ing<strong>w</strong>ave<sup>®</sup>-Coachings, ist eine CD erhältlich. Diese eignet sich besonders für Selbst-Coaching und zur Intensivierung von kreativen Prozessen. Hier wird die Hemisphären-Stimulation über Töne aktiviert, die mit leichter Musik unterlegt sind. Das Selbst-Coaching mit der CD erzeugt beim Management von Stress erstaunlich schnelle Erfolge.</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>

Does anyone know a solution? Thank you!

Attachments (1)

full_example.zip (6.3 KB) - added by gocher 13 years ago.
in this Example with an other submit handler you can see the error!!

Download all attachments as: .zip

Change History (13)

comment:1 Changed 13 years ago by gocher

You can't submit anything from IE in rev 384!

comment:2 Changed 13 years ago by gocher

Sorry the message before isn't correct! After you submit that text, Xinha can't submit anything!

comment:3 Changed 13 years ago by gocher

I tested your code with the ext_example in the example folder and it works!

comment:4 Changed 13 years ago by stef

Hallo gocher,

are you sure? I tested it also in ext_example: I deleted the old text, switched to "Toggle HTML Source", copied the above text into it and switched back to Wysywig-Mode. When I press "submit" the javascript-window with the text opens, but when I press enter (or click on OK) the popup-window closes but the form is not reloading. Thus the form is not sent to the server. If I do the same with the example text (Lorem ipsum ...) the form is correctly reloaded.

Have you also checked the reloading or only the opening of the confirmation pop-up?

Thank you for your help!

Stef

comment:5 Changed 13 years ago by Kim Steinhaug

I tested your code now in the latest SVN and in an older version, dated 20 September and they both submitted without problems. (The 20 September version is in our CMS).

So I cannot replicate the problem, I'm running IE 6.0.2800.1106

comment:6 Changed 13 years ago by gocher

Hallo Stef,

I tested it with ext_example not with the full_example, with the full_example you gets a popup and with the ext_example you get's the result in source and as preview in the editors frame!

I took the ext_example from Revision 385 and it works with full_example it doesn't!

I'm running IE 6.0.2900.2180.xpsp_sp2_gdr.050301-1519

Changed 13 years ago by gocher

in this Example with an other submit handler you can see the error!!

comment:7 Changed 13 years ago by Stef

Hallo gocher,

thank you for your messages!

a) message from Oct 6:
Because of the problems I downloaded xinha on Thursday again. With this version neither ext_example nor full_example works with the upper text.

b) message from Oct 7:

I downloaded your file full"_example.zip" and copied the files into the example-directory, replacing the old files. However, I see no difference in the behavior. Still I am not able to send the form. If I press "Halt on the next action" and continue the running of the script with F5 I get now the error message "htmlfile: access denied" (instead of syntax error). What was I supposed to see?

Thank you for looking for a solution!

Stef

comment:8 Changed 13 years ago by Stef

Hallo Kim,

I downloaded the trunk-Version from the CMS. The problem is still there. The window with the code is shown after pressing submit but the form is not sent.

Stef

comment:9 Changed 13 years ago by gogo

Can you isolate in which revision you first see the problem? Then we can see exactly what changed and why it may cause your problem.

You can easily step back/forward through revisions if you use a subversion tool like the svn command line client or TortoiseSVN (just "update" to a specific revision number, doesn't matter if it's earlier or later than the current revision you have checked out).

comment:10 Changed 13 years ago by gogo

  • Milestone set to Version 1.0
  • Severity changed from blocker to critical

comment:11 Changed 13 years ago by gocher

I have no errors with this patch:

Index: full_example-body.html
===================================================================
--- full_example-body.html	(revision 485)
+++ full_example-body.html	(working copy)
@@ -127,22 +127,28 @@
 
       HTMLArea.startEditors(xinha_editors);
     }
+      /** javascript submit handler ********************************************
+      * this shows how to create a javascript submit
+      * button that works with the htmleditor.
+      *************************************************************************/
 
+      submitHandler = function(formname) {
+        var form = document.getElementById(formname);
+        // in order for the submit to work both of these methods have to be called.
+        form.onsubmit();
+        alert(document.getElementById("myTextarea0").value);
+        form.submit();
+      }
+
     window.onload = xinha_init;
   </script>
-  <!--link type="text/css" rel="alternate stylesheet" title="blue-look" href="../skins/blue-look/skin.css" />
-  <link type="text/css" rel="alternate stylesheet" title="green-look" href="../skins/green-look/skin.css" />
-  <link type="text/css" rel="alternate stylesheet" title="xp-blue" href="../skins/xp-blue/skin.css" />
-  <link type="text/css" rel="alternate stylesheet" title="xp-green" href="../skins/xp-green/skin.css" />
-  <link type="text/css" rel="alternate stylesheet" title="inditreuse" href="../skins/inditreuse/skin.css" />
-  <link type="text/css" rel="alternate stylesheet" title="blue-metallic" href="../skins/blue-metallic/skin.css" /-->
 </head>
 
 <body>
 
-  <form id="editors_here">
-    <textarea id="myTextArea" name="myTextArea" rows="10" cols="80" style="width:100%"></textarea>
-    <textarea id="anotherOne" name="anotherOne" rows="10" cols="80" style="width:100%"></textarea>
+  <form id="to_submit">
+    <div id="editors_here"></div>
+    <button type="submit" onclick="submitHandler('to_submit');">Submit</button>
   </form>
 
 
Index: full_example.js
===================================================================
--- full_example.js	(revision 485)
+++ full_example.js	(working copy)
@@ -112,7 +112,7 @@
   }
 
 
-  var f = document.forms[0];
+  var f = document.getElementById("editors_here");
   f.innerHTML = '';
 
   var lipsum = document.getElementById('lipsum').innerHTML;
@@ -133,23 +133,4 @@
 
     div.appendChild(txta);
     f.appendChild(div);
-  }
-  
-  //check submitted values
-  var submit = document.createElement('input');
-  submit.type = "submit";
-  submit.id = "submit";
-  submit.value = "submit";
-  f.appendChild(submit);
-  
-  var _oldSubmitHandler = null;
-  if (document.forms[0].onsubmit != null) {
-    _oldSubmitHandler = document.forms[0].onsubmit;
-  }
-  function frame_onSubmit(){
-    alert(document.getElementById("myTextarea0").value);
-    if (_oldSubmitHandler != null) {
-      _oldSubmitHandler();
-    }
-  }
-  document.forms[0].onsubmit = frame_onSubmit;
\ No newline at end of file
+  }
\ No newline at end of file

comment:12 Changed 12 years ago by gogo

  • Resolution set to invalid
  • Status changed from new to closed

I'm closing this, it seems that only the reporter can repeat the problem and no other reports of similar, which indicates to me that it's something the reporter is doing.

Note: See TracTickets for help on using tickets.