Opened 14 years ago

Closed 14 years ago

#528 closed defect (fixed)

toolbar buttons are no longer updated after setHTML is used in full page mode (IE only)

Reported by: jschipf@… Owned by: gogo
Priority: normal Milestone:
Component: Plugin_FullPage Version:
Severity: normal Keywords:
Cc:

Description

When the editor is configured to run in full page mode, and setHTML is used, the toolbarButtons are no longer updated.

This can simply be reproduced using the view source button to switch between wysiwyg and text mode. When in text mode again, a click on a bold text does not set the bold button as active.

Change History (3)

comment:1 Changed 14 years ago by anonymous

See ticket 434 to see how bad this really is for your users when they edit full HTML pages using Xinha.

If it is the same bug, it works in Mozilla and breaks in IE. This is an old bug from HTMLArea3 that has probably not been fixed because it only affects full page users.

If it happened to people using Xinha to edit little blocks of text, it would be a major problem.

comment:2 Changed 14 years ago by gogo

  • Component changed from Xinha Core to Plugin_FullPage

anon: patches are very welcome.

comment:3 Changed 14 years ago by gocher

  • Resolution set to fixed
  • Status changed from new to closed

the problem with the fullpage mode is fixed in Revisin 401

button state works in firefox since Revision 402 in Firefox

Note: See TracTickets for help on using tickets.