Opened 14 years ago

Closed 14 years ago

#492 closed defect (fixed)

Problem with FormOperations Plugin when changing language

Reported by: 55 Digits Owned by: gogo
Priority: high Milestone: Version 1.0
Component: Plugin_Other Version:
Severity: critical Keywords: FormOperations
Cc:

Description

Hi there,

first of all, sorry for my english ;-).

I noticed the error when i changed my editor language from "en" to "de". In IE there's no error shown, but unfortunately, firefox shows a 404 error.

In the xinha example it works as well, but not in my editor. the only difference should be that i'm not using skins and that i change the language in the config in the file which contains the editor.

Waiting for helping answers.

55

Change History (14)

comment:1 Changed 14 years ago by anonymous

  • Component changed from Documentation to Xinha Core
  • Owner changed from akaEdge to gogo

comment:2 Changed 14 years ago by anonymous

  • Milestone set to Version 1.0
  • Priority changed from normal to high

comment:3 Changed 14 years ago by niko

please provide a demo-site where we can see your problem.

does it still work if you turn the language back to en?

comment:4 Changed 14 years ago by 55 Digits

I installed the demo-site. You can see it at

http://clab.xargo.de/test.php

. To Change the language, click the "Change language" link at the top.

comment:5 Changed 14 years ago by 55 Digits

I forgot to answer your question if it still works if i turn the language back to en: No, it doesn't work. I think you'll on the demo-site.

comment:6 Changed 14 years ago by niko

if it doesn't work either in english i assume the problem is not the language.

i thested your demo-page in FF, it worked! could you provide a bit more what error you get (especially WHEN and WHERE)
(or do you use Deer Park?)

comment:7 Changed 14 years ago by gocher

I tested http://clab.xargo.de/xinha/examples/full_example.htm and it fails too!

The error doesn't appears if you don't use FormOperations?, check that plugin!!!!!!

comment:8 Changed 14 years ago by 55 Digits

  • Resolution set to fixed
  • Status changed from new to closed

You're right, gocher.

It seems that the FormOperations? Plugin is the problem. I'll turn it off. Maybe someone could tell the developer of the FormOperations? Plugin, that there's an error changing the language in Firefox.

*fixed*

comment:9 Changed 14 years ago by 55 Digits

  • Component changed from Xinha Core to Plugin_Other

comment:10 Changed 14 years ago by 55 Digits

  • Keywords TableOperations added
  • Resolution fixed deleted
  • Severity changed from normal to critical
  • Status changed from closed to reopened
  • Summary changed from Error 404 is shown in Firefox if language is set to "de" to Problem with TableOperations Plugin when changing language

comment:11 Changed 14 years ago by 55 Digits

By the way: I deleted the demo page. For testing, visit xinha example site, http://xinha.gogo.co.nz/xinha-nightly/examples/full_example.html .

comment:12 Changed 14 years ago by 55 Digits

  • Keywords FormOperations added; TableOperations removed
  • Summary changed from Problem with TableOperations Plugin when changing language to Problem with FormOperations Plugin when changing language

Sry, mistake in the headline...

comment:13 Changed 14 years ago by gocher

As i wrote
"I tested http://clab.xargo.de/xinha/examples/full_example.html and it fails too!
The error doesn't appears if you don't use FormOperations?, check that plugin!!!!!!"

I mean test that plugin in "your" plugin folder, the example on site
http://xinha.gogo.co.nz/xinha-nightly/examples/full_example.html works!

comment:14 Changed 14 years ago by 55 Digits

  • Resolution set to fixed
  • Status changed from reopened to closed

With your fix in the newest revision, it works. Thanks!

Note: See TracTickets for help on using tickets.