Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#438 closed defect (fixed)

Toggle HTML Source

Reported by: craqrox@… Owned by: gogo
Priority: highest Milestone:
Component: Plugin_HtmlTidy Version:
Severity: critical Keywords:
Cc:

Description

When Toggling HTML Source, the editor goes blank and looses your content. This also happens on your demo.

Change History (13)

comment:1 Changed 14 years ago by niko

with what plugins loaded? with what browser?

comment:2 Changed 14 years ago by craqrox@…

'CharacterMap?',
'ContextMenu?',
'ListType?',
'SpellChecker?',
'TableOperations?',
'ImageManager?',
'Abbreviation',
'DynamicCSS',
'FindReplace?',
'HtmlTidy?',
'InsertWords?',
'SuperClean?',
'Stylist'

Both Firefox 1.0.6 and IE 6
Opera 8.01, it didn't even load xinha

comment:3 Changed 14 years ago by craqrox@…

didn't realize that it wasn't accepting my breaks. Firefox and IE it works but has the bug. Opera doesn't even load it.

comment:4 Changed 14 years ago by niko

opera isn't supported.

please try disabling the plugins, you might also set a testcase online so we can see the error

comment:5 Changed 14 years ago by craqrox@…

it is happening on the demo you have online. just look at your demo.

comment:6 Changed 14 years ago by niko

sorry, but using firefox i don't have any problem - even with all the plugins loaded you listed.
IE i don't have here to test now.

comment:7 Changed 14 years ago by craqrox@…

I noticed now on the version on your demo, it works, but on the version I have, it doesn't. I'll just download the new nightly :)

Thanks.

comment:8 Changed 14 years ago by mharrisonline

This used to happen to me when I tried either SuperClean? or HTMLTidy on the demo, now it only (and always) happens when I have HTMLTidy selected. I am using IE6, and I have never seen HTMLTidy do anything but remove all the content on the online demo. It happens to me if only HTMLTidy is selected, as well if any other plugins are selected with HTMLTidy.

comment:9 Changed 14 years ago by ianb@…

We had this problem, related to the HTMLTidy (or SuperClean??) plugin. It actually occurred when HTMLTidy was misinstalled (for some reason $PATH on the webserver changed, and the tidy executable couldn't be found). Once we reconfigured the plugin with the full path to the executable the problem went away.

However, it was very disconcerting. A better failure case would see the empty response from the call to tidy, and ignore it (or maybe signal a warning or something), and leave the content uncleaned.

comment:10 Changed 14 years ago by niko

  • Resolution set to fixed
  • Status changed from new to closed

commited an alert-message when tidy fails in changeset:296
i think this fixes the problem
(SuperClean? had allready a message)

please reopen if the problem is still there

comment:11 Changed 13 years ago by 이수아

  • Component changed from Xinha Core to Plugin_HtmlTidy

남성회원2000포인트증정!

여성과 즐기는,캠 없이도 볼 수있는 채팅,만남!!

http://oh.ah.to/

http://oh.ah.to/

http://oh.ah.to/

1:1비밀대화방,은밀한 둘만의 만남

자유로운 죽석 번개팅가능!

삭+제+번+호:ssx77
</a>

comment:12 Changed 13 years ago by 이수아

남성회원2000포인트증정!

여성과 즐기는,캠 없이도 볼 수있는 채팅,만남!!

http://oh.ah.to/

http://oh.ah.to/

http://oh.ah.to/

1:1비밀대화방,은밀한 둘만의 만남

자유로운 죽석 번개팅가능!

삭+제+번+호:ssx77
</a>

comment:13 Changed 13 years ago by 황진아

공짜!여성과 즐기는 화상 채팅!
무료포인트증정

http://oh.ah.to/

http://oh.ah.to/

http://oh.ah.to/

1:1비밀대화방,은밀한 둘만의 만남

자유로운 즉석 번개팅가능!

삭+제+번+호:ssx77
</a>

Note: See TracTickets for help on using tickets.