Opened 14 years ago

Closed 13 years ago

#387 closed defect (fixed)

Imagedialog IE bug, "A runtime error has occured"

Reported by: Kim Steinhaug Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: major Keywords: error, ie, image
Cc:

Description

When using IE there is still some bugs with the popup windows. Here is how to reproduce the bug,

Enter the latest example of Xinha on the site, insert an image somewhere. Be sure that the cursor is placed anywhere but the image. Rightclick on the image and choose the "Image properties", this will result in a javascrtipt error :

A runtime error has occured.
Line 75
Error: Dialog._modal" is null or not an object

The line is this in the file dialog.js :
Dialog._modal.focus();

If you left click on the image and then rightclick you wont get the error, so its important that the focus is somewhere else, then rightclick directly on the image and choose image properties.

Change History (3)

comment:1 Changed 14 years ago by Kim Steinhaug

Some research and I see this could have something to do with changeset #250.
http://xinha.python-hosting.com/ticket/250

comment:2 Changed 14 years ago by Kim Steinhaug

Hmm.. Could it be that when right clicking on the image it isnt accually selected, meaning as for Xinha a selection is done by leftclicking the image. Here we rightclick, which in turn does a selection in the editor, just that Xinha doesnt see that selection.

Maby adding an extra event or something for the right click button?

comment:3 Changed 13 years ago by ray

  • Resolution set to fixed
  • Status changed from new to closed

could not reproduce it anymore... seems to be fixed

Note: See TracTickets for help on using tickets.