Opened 14 years ago

Closed 14 years ago

#363 closed defect (invalid)

Absolute and Relative links

Reported by: gjajj Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

Hi I am having trouble with Absolute and Relative links.

The editor is setup in a different domain (eg. http://editor.com) from the actual site (http://mysite.com).

The problem occurs because the current pages are being pulled from an MySQL database which have all been entered using relative URL's (/en) instead of (http://mysite.com/en).

The problem is everytime I open a page in (http://editor.com) it replaces the relative URL (/en) with (http://editor.com/en) which does not exist.

A larger problem exists cause some of the pages entered are using absolute as well pointing to another domain!.

I just want for it to stop chaning the URL's altogether and leave them the way they are or at the least leave the relative URL's alone and stop converting them to absolute.

Change History (2)

comment:1 Changed 14 years ago by wreimer@…

Have you experimented with config.baseURL? I'm not sure of all the changes in Xinha, but in HTMLArea 3 I think if you set the base URL of the iframe document to your site's base url, it might take care of the problem... Also, stripBaseUrl() should be removing it in order to preserve relative links...

comment:2 Changed 14 years ago by gogo

  • Resolution set to invalid
  • Status changed from new to closed

-> Forum

Essentially dup of a "bug" to look at the url replacing stuff.

Note: See TracTickets for help on using tickets.