Opened 14 years ago

Closed 13 years ago

#359 closed defect (wontfix)

strike/list bug

Reported by: ursm@… Owned by: gogo
Priority: normal Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: major Keywords: list strike
Cc:

Description (last modified by gocher)

  • create a numbered list (like this one)
  • enter some text (like 'test')
  • select the text (only the text, not the list)
  • select strikeout
  • go to the end of the line and hit enter

BUG: no new list item is created, instead a new paragraph is shown

Change History (6)

comment:1 Changed 14 years ago by gocher

  • Description modified (diff)

comment:2 Changed 14 years ago by ursm@…

Another way of currupting a list

  • Create a numbered list (* This is a list * Second line)
  • Select 'Second line' and make strikeout
  • now select 'This is a list' and copy
  • place the cursor in front of Second: * |Second
  • paste
  • you can see that now <strike> is surrounding <li> which is invalid, and any modification to the list will corrupt the text
  • for instance hitting enter after the end of the second line will result in merging list items together, ...

comment:3 Changed 14 years ago by Urs C Muff <ursm@…>

Gogo are you working on this, or should it be reassigned?

comment:4 Changed 14 years ago by gogo

  • Milestone set to Version 1.0
  • Priority changed from highest to normal
  • Severity changed from blocker to major

I'm the default assignee for tickets, everything not assigned is assigned to me. I havn't looked at this, if somebody else wants to take it, by all means.

PS: this isn't a blocker - a blocker is a bug that breaks the system totally so that further work cannot be done until it's fixed.

comment:5 Changed 14 years ago by gogo

I can't reproduce either of these. I presume the bug is exhibited only by mozilla (if it's IE then too bad nothing we can do), so what paraHandler setting are you using?

comment:6 Changed 13 years ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

I don't think there is anything we can do about these

Note: See TracTickets for help on using tickets.