Opened 14 years ago

Closed 14 years ago

#337 closed defect (fixed)

toolbar icons/buttons are displayed vertically; not horizontally in toolbar

Reported by: rob at robshepherd dot net Owned by: gogo
Priority: highest Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: blocker Keywords:
Cc: gogo

Description

The toolbar icons are displayed in a vertical line not in horizontal lines in the toolbar.
The first one is where it should be, positioned correctly.
The buttons are usable but displayed wrong,

this bug is apparent in IE but not firefox.

setup from the newbie guide. single textarea.

Attachments (4)

back.zip (82.6 KB) - added by gocher 14 years ago.
back to changeset 216 with all changes of changset 235 without toolbar
htmlarea.js.patch (10.3 KB) - added by gocher 14 years ago.
htmlarea.js patch file for revision 253
htmlarea.css.patch (3.1 KB) - added by gocher 14 years ago.
htmlarea.css patch file for revision 253
skins.patch (11.5 KB) - added by gocher 14 years ago.
all skin.css patch file for revision 253

Download all attachments as: .zip

Change History (21)

comment:1 Changed 14 years ago by niko

  • Priority changed from normal to highest
  • Severity changed from critical to blocker
  • Version set to trunk

i can confirm this :(

#323 #329 #335

please fix this asap!!!

comment:2 Changed 14 years ago by ianb@…

I also noticed this problem at the same time #314 occurred. Toolbar wrapping changed how IE acted, but both ways it was broken.

comment:3 Changed 14 years ago by anonymous

delete line

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

and it works

comment:4 Changed 14 years ago by gocher

No I think that's the better way!
look at W3C

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html 
     PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

comment:5 Changed 14 years ago by gocher

sorry better whole path

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html 
     PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

comment:6 Changed 14 years ago by gogo

gocher this is still broken, your new toolbar stuff doesn't work in IE when document.compatMode reports CSS1Compat, only when it reports BackCompat?. Please fix immediatly.

comment:7 Changed 14 years ago by niko

xinha should work correctly in strict-mode AND in quirks mode!!

changing the doctype isn't an options for everybody (if the rest of the CMS doesn't work in strict)

comment:8 Changed 14 years ago by gogo

  • Cc gocher added
  • Milestone set to Version 1.0

comment:9 Changed 14 years ago by gogo

  • Cc gogo added; gocher removed
  • Owner changed from gogo to gocher

comment:10 Changed 14 years ago by gogo

It's worse than that niko, currently iut doesn't work in struct mode, only in quirks :-(

Changed 14 years ago by gocher

back to changeset 216 with all changes of changset 235 without toolbar

comment:11 Changed 14 years ago by gocher

  • Owner changed from gocher to gogo

Should I insert the old toolbar with table elements, it's no problem?
The files are in attached (back.zip)!

comment:12 Changed 14 years ago by gogo

If you are unable to fix this gocher then I will revert your changes. Please advise.

comment:13 Changed 14 years ago by gocher

I cant't fix it, because css1 has not all attributes which are important for that, sorry!

comment:14 Changed 14 years ago by mokhet

this problem is still active with changeset [252], can we have the backport or a fix as soon as possible ? Xinha is not usable at the moment with IE6 and a DTD <!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN" "http://www.w3.org/TR/html4/loose.dtd">

It is urgent to apply a fix or the backport.

Can not be see with the full_example because this page is not using any DTD and is falling in quirks mode, as most of the popups used by Xinha. Which is imo a wrong choice, especially because we can find a lot of xhtml element (<p />, <input />) in the popups but no DTD are never used. A choice should be made, or we are in XHTML and then we use the correct DTD or we are in quirks mode (HTML, not XHTML) and the XHTML tag should be removed. But a mix between HTML structure and XHTML tags is imo the worst choice available. We are standard or we are not, but mixing is not the magic answer.

To come back to this ticket, since it is working as intended in quirks mode, what is missing in CSS1 to make it works correctly in IE with a page using a standard DTD ?

Changed 14 years ago by gocher

htmlarea.js patch file for revision 253

Changed 14 years ago by gocher

htmlarea.css patch file for revision 253

Changed 14 years ago by gocher

all skin.css patch file for revision 253

comment:15 Changed 14 years ago by gocher

In CSS1 the for example "overflow: hidden;" and "position: relative;" is missing!
As attachment the are patches to set all changes of the toolbar back!

comment:16 Changed 14 years ago by anonymous

is there someone working on this problem ?

comment:17 Changed 14 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

In changeset:260 I have reverted the changes submitted by gocher that caused this problem.

Note: See TracTickets for help on using tickets.