Opened 14 years ago

Closed 14 years ago

#316 closed defect (invalid)

Integrate Xinha into a themeable system

Reported by: white@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: stylesheet theme
Cc:

Description

Right now I use Xinha in a web architecture I'm creating that is already themeable. Therefore, I want to Xinha to inherit the styles from the currently selected theme. To do this I've added the contents of Xinha's htmlarea.css file to my own css files, and change those styles for each theme.

The problem is that Xinha always includes htmlarea.css. It would useful to set a property that would keep Xinha from using htmlarea.css, instead assuming that the styles are already defined.

The htmlarea.css file is loaded both in htmlarea.js and popupwin.js.

Change History (2)

comment:1 Changed 14 years ago by anonymous

Imo the file htmlarea.css should never be altered or manually used.

cant you use the skins feature to get your theme instead of include htmlarea.css in your own css files ?

I think this ticket is invalid because i really think this is the purpose of /skins/

comment:2 Changed 14 years ago by mokhet

  • Resolution set to invalid
  • Status changed from new to closed

the skin system allow xinha editor to be themed. It will of course need you to create a dedicated skin, but that is the purpose of skins.

Note: See TracTickets for help on using tickets.