Opened 14 years ago

Closed 14 years ago

#285 closed defect (fixed)

IE: onreadystatechange

Reported by: ianb@… Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version: trunk
Severity: critical Keywords: ie
Cc:

Description

In revision 179, htmlarea.js, I'm getting an error in IE:

line: 5048
char: 7
error: Type Mismatch
code: 0

Commenting out this line fixes it, though I understand none of it...

--- htmlarea.js (revision 179)
+++ htmlarea.js (working copy)
@@ -5044,7 +5044,7 @@
       {
         alert('An error has occurred: ' + req.statusText);
       }
-      req.onreadystatechange = null;
+      //req.onreadystatechange = null;
     }
   }

Change History (2)

comment:1 Changed 14 years ago by niko

  • Priority changed from normal to high

i can confirm this error.
but i don't understand it *g*

comment:2 Changed 14 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

Looks like the offending code was removed at some time. Closing.

(NB: I imagine IE didn't like having null as a function reference into an ActiveX object, unfortunatly I bet it leaks memory like a sieve because of that)

Note: See TracTickets for help on using tickets.