Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#278 closed defect (duplicate)

Maximize Editor Screen Opening in Current Window

Reported by: IE and Firefox Maximize Window Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc:

Description

Before hand, HTMLArea opened a separate popup window for the Maximize Editor popup. Now, the editor maximizes into the current window. It no longer pops up into it's own window.

Tested in several themes for Drupal, but performs the same in all. Does the same thing in both Firefox and IE6.

Attachments (4)

capture1.png (58.8 KB) - added by anonymous 14 years ago.
capture2.png (24.2 KB) - added by anonymous 14 years ago.
capture3.png (33.4 KB) - added by anonymous 14 years ago.
capture4.png (37.2 KB) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 14 years ago by anonymous

  • Component changed from Documentation to Xinha Core
  • Owner changed from akaEdge to gogo

comment:2 Changed 14 years ago by Shane Birley

  • Version set to trunk

If this is by design, it shouldn't be as when the editor is minimized, the textarea that was "maximized" remains large on the site. It would scare the heeby-jeebies out of people.

comment:3 Changed 14 years ago by anonymous

  • Summary changed from Maximize Editor Screen Opening in Currnet Window to Maximize Editor Screen Opening in Current Window

comment:4 Changed 14 years ago by gogo

  • Priority changed from high to normal
  • Severity changed from major to normal

This is by design. The FullScreen? plugin now replaces the horribly broken popup system. When you click the maximize button the editor expands to the full window size, when you click the button again it goes back to normal.

Are you seeing some problem, can you describe more fully please.

comment:5 Changed 14 years ago by Shane Birley

The problem is when the screen expands it pushes all other elements of the web site over. In essence it blows the web site apart. So, if you force the window to open over top of anything, it just kills the site. Here are some screen shots.

  1. The screen as it appears when updating/editing/etc.
  2. The screen as it appears after clicking on "full screen" editing.
  3. The screen after it has returned to the point in the first capture.
  4. A capture showing you how everything it pushed out off the viewable screen.

I have tested this on a couple of sites with different layouts and it acts the same in both browsers.

It may be by design but it seems to destroy the site in the process. Perhaps I am using the plugin wrong?

Changed 14 years ago by anonymous

Changed 14 years ago by anonymous

Changed 14 years ago by anonymous

Changed 14 years ago by anonymous

comment:6 Changed 14 years ago by Shane Birley

I have just tested this further in both Firefox and IE6 and it just doesn't seem to be working at all. Screenshots taken in Firefox 1.0.4 on Windows XP.

comment:7 Changed 14 years ago by Shane

This also is working very strangely in IE6, but something new. The FullScreen? pops to the top left corner and doesn't change size at all. It is like it picks up the window and dumps it to the corner at the top.

comment:8 Changed 14 years ago by niko

perhaps xinha is inside an absolute/relative positioned div?
take a look at #119
(i wrote allready a small patch but it has bugs in FF i'm not able to fix)

comment:9 Changed 14 years ago by gogo

What is the version information from the about dialog in your editor please.

If you look at the Xinha example you can see the intended behaviour of the fullscreen button, it shuld make the editor absolutly positioned (take it out of the flow), at 0-0, make it large enough to fill the window space, and stop the window from scrolling it out of view. However if you have Xinha within a relative/absolute div then currently the positioning will be buggered up.

comment:10 Changed 14 years ago by Tableless Layouts

Well, the reality is, if the thing doesn't work in a website that doesn't use tables for the layout, the FullScreen? option is completely useless. I think this will need to be addressed since DIV layouts are becoming more popular and shouldn't be ignored. I don't design anything anymore without DIV layouts.

Maybe someone could develop and easier to handle pop up window option - which, I think would make Xinha a very powerful package. Have a FullScreen? (the current way) and PopFullScreen?.

I wish I were a coder, otherwise, I would help out and do it.

comment:11 Changed 14 years ago by gogo

  • Resolution set to duplicate
  • Status changed from new to closed

The popup system sucks ass and is difficult to write and maintain, if somebody wants to write a popup editor plugin by all means do, but I won't be.

This way is better, it just needs some tweaking to get around the positioning problem, remember, Xinha is unstable and in heavy development, that FullScreen? works for *most* people right now, and isn't an integral part of the editor, and of course you can turn it off if you don't want it.

See #119, closing as a dup of that.

comment:12 Changed 14 years ago by Shane

HAHAHAHAH! That is awesome! I would agree the system sucks donkey butt - yet, I am building sites for people who don't necessarily know anything about computers. So, having them freak out when something doesn't work is scary for them. That's all. On to ticket #119.

comment:13 Changed 14 years ago by gogo

Note: See TracTickets for help on using tickets.