Opened 14 years ago

Closed 13 years ago

#265 closed defect (duplicate)

full page plugin meta tag patches

Reported by: aldug@… Owned by: gogo
Priority: high Milestone: Version 1.0
Component: Plugin_FullPage Version: trunk
Severity: major Keywords: patch
Cc:

Description

I have a patch I wrote against htmlarea 3rc3 which adds meta tags to the full page proporties. Where should I send these patches?

Attachments (3)

full-page.diff (2.6 KB) - added by aldug@… 14 years ago.
full-page.2.diff (2.6 KB) - added by anonymous 14 years ago.
docprop.diff (960 bytes) - added by aldug@… 14 years ago.

Download all attachments as: .zip

Change History (11)

Changed 14 years ago by aldug@…

Changed 14 years ago by anonymous

Changed 14 years ago by aldug@…

comment:1 Changed 14 years ago by aldug@…

actually, I think these patches were against rc1

comment:2 Changed 14 years ago by anonymous

  • Summary changed from upll page plugin meta tag patches to full page plugin meta tag patches

comment:3 Changed 14 years ago by anonymous

Any word on getting these accepted?

comment:4 Changed 14 years ago by gogo

  • Keywords patch added
  • Milestone set to Version 1.0
  • Severity changed from normal to enhancement
  • Version set to trunk

They will be looked at before V1.0, enhancements have low priority at the moment. Unless you want to apply them youself and help with more javascript development - email james@… if you do.

comment:5 Changed 14 years ago by gocher

  • Resolution set to fixed
  • Status changed from new to closed

modified in changeset 248

comment:6 Changed 14 years ago by mharrisonline

  • Priority changed from normal to high
  • Resolution fixed deleted
  • Severity changed from enhancement to major
  • Status changed from closed to reopened

This change broke body attributes in Xinha in firefox with the full page plugin in . Body attributes began dissapearing from HTML files in full page config Xinha in firefox with changeset 177.

However, in firefox body attributes were still retained if the full page plugin was used. After changeset 248, the plugin no longer preserved the body attributes.

Changeset 177 broke body attributes in Xinha in firefox with htmlarea.js configured for full page. The full page plugin when used made attributes stay.

Changeset 248 broke the full page plugin in firefox by stopping it also from preserving body attributes.

This means that if background colors or images or other attributes are present in the body tag when Xinha is used in firefox, Xinha now strips the body tag down to <body>, corrupting content Xinha (and formerly HTMLArea3) was fully able to edit until changesets 177 and 248.

comment:7 Changed 14 years ago by gocher

look at Ticket #459

comment:8 Changed 13 years ago by ray

  • Resolution set to duplicate
  • Status changed from reopened to closed

duplicate of #459

Note: See TracTickets for help on using tickets.