Opened 13 years ago

Closed 13 years ago

#184 closed enhancement (duplicate)

Maxlength restriction (onKeyPress, onPaste), Chars counter (html tags excluded)

Reported by: gi_gio@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: maxlength chars counter
Cc:

Description

One of the major lacks (of course, this is my opinion) in HTMLArea was the missing maxlength feature. In HTMLArea 2, I managed to code some very simple and unefficient javascript into the editor.js file (I inserted some rows in the function editor_event(objname,runDelay), but it was very slow). I also managed to make the editor to display into an external text field the number of the available chars left. In HTMLArea 3, I haven't managed to do this. I'd like to write an appropriate plugin for Xinha, but I'm not familiar with the plugin structure, so .... can anyone help?

Thanks, gi_gio.

Change History (3)

comment:1 Changed 13 years ago by niko

could you post the code for calculating the chars without the tags, i probably could write such a plugin - as i could need it too :D

We must finde a place where to display the current and avaliable chars.
(perhaps in the status-bar? on the right so the path don't has to be changed?)

comment:2 Changed 13 years ago by gocher

look at Ticket #223 there is the CharCounter? plugin

comment:3 Changed 13 years ago by gogo

  • Resolution set to duplicate
  • Status changed from new to closed

This feature should be rolled into the charcounter plugin I think. Resolving this as duplicate of #223 , although it's not really, but close enough :)

Note: See TracTickets for help on using tickets.