Opened 15 years ago

Closed 13 years ago

#169 closed defect (worksforme)

deactivated editors with Firefox when there is more than one editor

Reported by: michael.hosse@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

This bug is already known, but the workaround in htmlarea.js did not work for me. So i tried some alternatives and found one. :-). It is very simple, just deactivate the editor an reactive it. Here is the patch for htmlarea.js:

Index: C:/workspace/xinha/htmlarea.js
===================================================================
--- C:/workspace/xinha/htmlarea.js	(revision 83)
+++ C:/workspace/xinha/htmlarea.js	(working copy)
@@ -1497,18 +1497,12 @@
     doc.write(html);
     doc.close();
     
+    // if we have multiple editors some bug in Mozilla makes some lose editing ability
+		if(HTMLArea.is_gecko)
+			editor.deactivateEditor();
+			
     // redo it for some obscure reason that IE need it..
     editor.activateEditor();
-    
-    // if we have multiple editors some bug in Mozilla makes some lose editing ability
-    if(HTMLArea.is_gecko)
-    {
-      HTMLArea._addEvents(
-        editor._iframe.contentWindow,
-        ["mousedown"],
-        function() { editor.activateEditor();  }
-      );
-    }
 
     // editor.focusEditor();
     // intercept some events; for updating the toolbar & keyboard handlers

Change History (5)

comment:1 Changed 15 years ago by michael.hosse@…

  • Summary changed from deactivated editors with Firefox when there are more than one editor to deactivated editors with Firefox when there is more than one editor

comment:2 Changed 14 years ago by gogo

Can you provide a reference to a discussion regarding this bug? I'm not sure what the problem is you were trying to solve is.

comment:3 Changed 14 years ago by anonymous

We are having the same problem, only seems to happen on Mozilla with multiple editors when the config.pageStyleSheets[0] = 'stylesheet.css' is set. It seems that the workaround above DOES seem to work. Thanks!

comment:4 Changed 14 years ago by anonymous

For clarification of the bug. When using Mozilla (IE works fine) and you place multiple editors on a single webpage, and you set the payStyleSheets settings...after the page loads only the last editor will be active. The others will not allow text entry...you can switch to HTMLMode and back, and that will fix the problem. The above workaround works!

comment:5 Changed 13 years ago by gogo

  • Resolution set to worksforme
  • Status changed from new to closed

I believe this is no longer necessary.

Note: See TracTickets for help on using tickets.