Opened 6 years ago

Closed 4 months ago

#1596 closed defect (wontfix)

TransformerInnerHTML.js hangs browser in raw image data "img" tag

Reported by: guest Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: TransformerInnerHTML.js, img tag, regexp,
Cc: ejucovy

Description

I am using Xinha to allow rich text editing in my web application. When the editor component gets an "img" tag with raw base64 encoded image data in it (see template file for html img data that cause the problem) the TransformerInnerHTML.js script hangs on the "cleanHTML" method. Probably the regular expression match and replace takes too long for these type of use cases. Problem is reproducible in Xinha 0.95. I haven't tried other Xinha versions.

Attachments (1)

raw_img_data.zip (243.9 KB) - added by guest 6 years ago.
Raw image data that cause the problem.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by guest

Raw image data that cause the problem.

comment:1 Changed 6 years ago by ejucovy

  • Cc ejucovy added

comment:2 Changed 4 months ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

WFM, Firefox 58

Probably time has marched on since this was reported and processor speed has caught up.

Also, putting that much Data URI in a page is a bad idea generally, and DOMWalk will be faster.

Note: See TracTickets for help on using tickets.