Opened 5 years ago

Closed 4 years ago

#1482 closed defect (duplicate)

Unable to handle more than one equation in editor

Reported by: guest Owned by:
Priority: normal Milestone: 0.96
Component: Plugins Version: trunk
Severity: normal Keywords: equations, asciimath, mathml
Cc:

Description

This is a rather catastrophic bug for anyone who's really using the Equations plugin. Basically it does not handle more than one equation in the editor correctly.

When you insert the first equation, all is well. When you insert a second (or subsequent) equation, then all the previous equations get converted to MathML tags within the <span> tag that's supposed to contain the ASCIIMath representation. However, the one you just entered is fine.

This is not apparent until you save and re-edit, or an even quicker way to see it is to enter code view in Xinha and then switch back to WYSIWYG view. All but the last equation become plain text.

This can be replicated on the online demo of both the 0.96 version and the latest nightly build.

Change History (2)

comment:1 Changed 5 years ago by guest

Sorry, I just noticed that this is a duplicate of #1182

Niraj Bhawnani
Research Assistant
University of New South Wales

comment:2 Changed 4 years ago by gogo

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.