Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1426 closed defect (invalid)

Plugin Stylist cannot work with CSS 2.1

Reported by: guest Owned by:
Priority: normal Milestone: 0.96
Component: Plugins Version: trunk
Severity: normal Keywords:
Cc:

Description

Stylist is blocking Xinha complete (no loading) if someone is using css 2.1

See http://powercms.org and the CSS is

http://powercms.org/tmp/cache/template_id_57_media_screen.css

with css 2.1 stylist is worthless.

Attachments (2)

Bildschirmfoto-Xinha Newbie Guide - Mozilla Firefox.png (93.2 KB) - added by ray 10 years ago.
Xinha working with supplied CSS
shot (46.5 KB) - added by guest 10 years ago.
Source of the page

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by guest

The css was a valid css !

Changed 10 years ago by ray

Xinha working with supplied CSS

comment:2 Changed 10 years ago by ray

Sorry, I can't reproduce the problem, see screenshot. If you could put up a test case where I can see the error, I'm sure we will find out what's going on there

Changed 10 years ago by guest

Source of the page

comment:3 Changed 10 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

Yuo have single quotes within the CSS string that cause a syntax error. I suggest you use xinha_config.stylistLoadStylesheet() instead of putting the whole CSS as a string, or you have to take care to properly escape your quotes

comment:4 Changed 10 years ago by guest

I changed all ' against "

I load a file with

xinha_config.stylistLoadStyles('is_only_a_filename');

Now it works !!! Thank you very much.
with

xinha_config.stylistLoadStylesheet('is_only_a_filename')

i have all the css in the Textarea - must be another Bug.

Note: See TracTickets for help on using tickets.