Opened 8 years ago

Closed 8 years ago

#1383 closed defect (fixed)

IE 7 Secure and Nonsecure Warning

Reported by: guest Owned by:
Priority: normal Milestone: 0.96
Component: Browsers_InternetExplorer Version: trunk
Severity: normal Keywords: IE secure nonsecure SSL HTTPS
Cc: j.potts@…

Description

Receive "Secure and nonsecure items" warning when loading examples on an SSL site:

https://www.pottsdevelopment.com/xinha/examples/list.html

list.html is added; all other files are unmodified Xinha 0.95.

I've seen older tickets for this, but entered one since I can easily reproduce it using unmodified example files.

Change History (2)

comment:1 Changed 8 years ago by guest

Did some more testing. This is directly related to:

Xinha.addOnloadHandler(xinha_init);

and if replaced with:

window.onload = xinha_init;

... it works on at least IE 7 (displays Xinha over SSL without any browser warnings).

Since I'm new to Xinha, I don't know if this is a valid workaround or is a kludge that happened to work, so I'll leave the ticket open.

Keep up the great work!

comment:2 Changed 8 years ago by ray

  • Resolution set to fixed
  • Status changed from new to closed

rev [1157]. Thanks for submitting the report and you good analysis, this helps a lot :)

Note: See TracTickets for help on using tickets.