Opened 8 years ago

Closed 7 years ago

#1379 closed defect (wontfix)

Image heights get recalcuated/screwed up when images fail to load

Reported by: nicholasbs Owned by:
Priority: normal Milestone: 0.97
Component: Browsers_Firefox Version: trunk
Severity: normal Keywords:
Cc:

Description

If at some point after adding an image to your Xinha document the image cannot be loaded (e.g., because you're offline or the server hosting the image cannot be reached), the dimensions of the image will be recalculated to fit the size of the image's file name which is displayed in its place. The problem is that when the image is able to be loaded again, the width and height will remain as they were (e.g., for just the file name).

This only happens when using DOMwalk; TransformInnerHTML works correctly.

This appears to only be a FF3 bug, since it works fine in Safari 3 and IE6.

Change History (1)

comment:1 Changed 7 years ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

I expect that this is

  • browser behaviour
  • can't be fixed nicely
  • probably shouldn't have any effort put into it

closing won't fix.

Note: See TracTickets for help on using tickets.