Opened 10 years ago

Closed 10 years ago

#1324 closed defect (fixed)

linker email link - no email field

Reported by: guest Owned by:
Priority: normal Milestone: 0.96
Component: Plugins Version: trunk
Severity: blocker Keywords:
Cc:

Description

nightly demo with the linker plugin.

  1. select text and click link button.
  2. then click email link.

there is no option to enter an email address.

FF3

Adam J

Change History (4)

comment:1 Changed 10 years ago by douglas

  • Resolution set to worksforme
  • Status changed from new to closed

I just went to the nightly, selected linker, clicked the reload button in the bottom left of the page, and it gave me an email option. Did you reload the editor after selecting Linker? If you still have problems, come into irc://irc.freenode.net/#xinha and we'll try to help you out...

comment:2 Changed 10 years ago by guest

  • Resolution worksforme deleted
  • Status changed from closed to reopened

just tried this again.

it worked first time. then i did it with 2 editors and opened and cancelled a few times and it stopped working.
there's definitely a bug there - but it's not as easy to reproduce as I stated before.

i also keep getting this js error:

Error: console is not defined
Source File: http://www.xinha.org/xinha-nightly/plugins/Linker/Linker.js
Line: 630

comment:3 Changed 10 years ago by douglas

Reproduced using the following instructions:

  1. Go the the nightly demo
  2. Specify 2 editors on the left, with the linker plugin enabled
  3. Open the linker dialog in the first Xinha and choose email (it shows)
  4. Click cancel
  5. Open the linker dialog in the second Xinha and choose email (it shows)
  6. Click cancel
  7. Open the linker dialog in the first Xinha and choose email (nothing shows!!!)

I've done some rudimentary debugging, and it turns out that on the third time around, clicking the link is trying to access the dialog from the other Xinha, and so it's showing the wrong elements...

comment:4 Changed 10 years ago by ray

  • Resolution set to fixed
  • Status changed from reopened to closed

rev [1118]: small bug, but hard to spot.

Lesson to learn: Don't forget to declare variables with var, unless you want to use a variable from a different scope!

Note: See TracTickets for help on using tickets.