change naming scheme of plugin files
|Reported by:||ray||Owned by:||gogo|
Why are the plugin files named as they are? In case anyone knows, plaese let me know ;) However I don't like it at all and I think it's a big obstacle for would be plugin authors. I once started writing a plugin tutorial and I just failed explaining the scheme. IMHO the files should be named like the folders and the functions and the name by which it is loaded. Problem of course is backward compatibility, because at the moment loading fails completely when a file is not found.
I have written a path that uses HEAD requests to test whether a file exists. Of cost this costs a few milliseconds, but I think this is affordable and has also the benefit of gracefully skipping plugins that are not found. A message is printed to the console in either case, plugin using the old scheme and plugin not found.
Additionally I there is a considerable speed increase, because I lowered the interval in which the plugin loading status is queried, so I have the hope that overall loading time at least with chached filesis reduced, in spite of the extra requests.