Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1290 closed defect (fixed)

Word clean doesn't properly clean all word garbage from document

Reported by: douglas Owned by: douglas
Priority: normal Milestone: 0.96
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc: douglas@…

Description (last modified by douglas)

I have a document that isn't properly cleaned when pasting into word.

Here is some supporting info:
http://www.openplans.org/projects/xinha/wordclean

Attachments (1)

Xinha-Word 2003 Paste Issue.doc (80.0 KB) - added by guest 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by guest

comment:1 Changed 8 years ago by guest

Steps to reproduce:

Copy and paste contents of Word 2003 attachment into Xinha in Firefox 2.

Expected Results:
Xinha cleans all garbage word tags.

Actual Results:
Word garbage remains on FF2/3, IE7. Text visible.
In FF2, text is NOT visible at all.

comment:2 Changed 8 years ago by ray

While you're at it: OpenOffice? produces junk like this

 <meta http-equiv="CONTENT-TYPE" content="text/html; charset=utf-8" /> <title></title> <meta name="GENERATOR" content="OpenOffice.org 2.4  (Linux)" /> <style type="text/css">
	<!--
		@page { size: 21cm 29.7cm; margin: 2cm }
		P { margin-bottom: 0.21cm }
	-->
	</style> 
  <p style="margin-bottom: 0cm;">Fdfsdfsd</p> 

Any chance you can fix this, too?

comment:3 Changed 8 years ago by douglas

r1053 advances this ticket, but it may need some more work. On Monday, I'll compare against this test case:
http://pastie.org/284533

comment:4 Changed 8 years ago by douglas

  • Cc douglas@… added
  • Owner changed from gogo to douglas

comment:5 Changed 8 years ago by douglas

r1068 fixes this in my test cases. I'm sending the fix around to be tested by others.

comment:6 Changed 8 years ago by douglas

It turns out I was accidentally testing against a cached copy. r1069 fixes this with working and tested code.

comment:7 Changed 8 years ago by douglas

  • Resolution set to fixed
  • Status changed from new to closed

r1073 is my final fix against this ticket. http://www.openplans.org/projects/xinha/wordclean documents the testing that's been done against it, and I'm satisfied for the most part. For any additional work, I'll open a new ticket.

comment:8 Changed 8 years ago by douglas

  • Description modified (diff)
Note: See TracTickets for help on using tickets.