Opened 9 years ago

Closed 9 years ago

#1208 closed defect (invalid)

Opening a new window clicking on icon?

Reported by: guest Owned by: gogo
Priority: normal Milestone: 0.95
Component: Xinha Core Version: trunk
Severity: major Keywords:
Cc:

Description

I would like to open my own window when i click on the icon for adding new images. But I can't.

From file XinhaCore?.js, there is line of code which starts with this.URIs. I have modified it (whole modification is not here, because it is large piece of code):

this.URIs={"insert_image":"http://127.0.0.1/magicus/administracija/Xinha_0.95_RC2/popups/insert_image.php?kostur_grupa=\" + global_a + \"&lan_path=\" + lan_path + \"&g_projekt=\" + g_projekt, editdoc, \"resizable: no; help: no; status: no; scroll: no; dialogWidth:680px;\"};

With this path after "insert_image":" I can't open my window, and I'm getting an error that globalDoc has no properties.
Notice that in my path there is a script insert_image.php.
In there, there is javascript stuff which is needed when window is opened via showModalDialog.
globalDoc is declared in that file - insert_image.php

If I change above code in this, I'm not getting an error, because I even open new window:
this.URIs={"insert_image":showModalDialog(_editor_url +"http://127.0.0.1/magicus/administracija/Xinha_0.95_RC2/popups/insert_image.php?kostur_grupa=\" + global_a + \"&lan_path=\" + lan_path + \"&g_projekt=\" + g_projekt, editdoc, \"resizable: no; help: no; status: no; scroll: no; dialogWidth:680px;\");"};

I presude that I can open new window only with showModalDialog, because only in that way I can choose images from my cms administration becasuse of parameters in file insert_image.php which I require.

How could I open the new window with correct path, that would't throw an error, and would work?

Change History (3)

comment:1 Changed 9 years ago by guest

P.S.
This line of my text:
If I change above code in this, I'm not getting an error, because I even open new window:

Should be:
If I change above code in this, I'm not getting an error, because I can't even open new window:

comment:2 Changed 9 years ago by guest

My e-mail is dddario1 monkey yahoo dot com
I would appreciate your help

comment:3 Changed 9 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug. It seems you are trying to configure the URI for the InsertImage? dialog with a JavaScript call. This does not work, it just hast be a simple URI

Note: See TracTickets for help on using tickets.