Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1206 closed defect (invalid)

Problem with starting editor in my site

Reported by: guest Owned by:
Priority: normal Milestone: 0.95
Component: Website Version: trunk
Severity: major Keywords:
Cc:

Description

I have a big problem - I can't start editor in my site. I usually have been loading previuous html editor throught PHP function. Now, I just replaced the old editor code with new code. This code you can see here, is executed locally, and I have copied this code from examples folder, file "simple_example.html" and modified it so it could be run on my site. Version is Xinha_0.95_RC2. But nothing is showing. Please help, I think something is wrong with paths, but I don't understand what.
When I copy path - http://127.0.0.1/mysite/administration/Xinha_0.95_RC2/XinhaCore.js which is in code as you can see, and paste it in my Internet browser, I can open that XinhaCore?.js file - that means path is good and I haven't misspell it code. However, I can't opet editor in my site, although paths seem to be good.

I'm trying this in many ways, but with no results. Sorry for my English; hope somebody can help me? Dario, Croatia
My e-mail is dddario1 monkey yahoo.com

$result .= "<script type=\"text/javascript\">

var _editor_url = document.location.href.replace(/examples\/simple_example\.html.*/, )
var _editor_url = 'http://127.0.0.1/mysite/administration/Xinha_0.95_RC2/';


var _editor_lang = \"en\";
</script>
<!-- Load up the actual editor core -->
<script type=\"text/javascript\" src=\"http://127.0.0.1/mysite/administration/Xinha_0.95_RC2/XinhaCore.js\"></script>
<script type=\"text/javascript\">


var xinha_plugins =
[

'Linker'

];
var xinha_editors =
[

'myTextArea',
'anotherOne'

];


function xinha_init()
{

if(!Xinha.loadPlugins(xinha_plugins, xinha_init)) return;


var xinha_config = new Xinha.Config();


xinha_editors = Xinha.makeEditors(xinha_editors, xinha_config, xinha_plugins);


Xinha.startEditors(xinha_editors);

}
Xinha.addOnloadHandler(xinha_init);
</script>";



return $result;

Change History (2)

comment:1 Changed 11 years ago by wymsy

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug, please ask questions in the forum.

comment:2 Changed 11 years ago by guest

I was banned from forum after 2 minutes after I asked this same question!

Nevertheless, I solve that problem, so you can delete it.

Note: See TracTickets for help on using tickets.