Opened 7 years ago

Closed 7 years ago

#1197 closed defect (fixed)

[Linker] Patch for files[i].length, IE shows bug in line 262

Reported by: guest Owned by:
Priority: normal Milestone: 0.95
Component: Plugins Version: trunk
Severity: major Keywords: Linker, length, Internet Explorer, IE
Cc: roman@…, guest

Description

On loading editor, IE shows bug in line 262, that length is empty or isn't object.

I think it's a line 423 in linker.js where is a test for array. I propose other condition for testing, instead of:

    else if(files[i].length)

do:

    else if(typeof files[i]=="object" && files[i] && typeof files[i].length==="number")

Cheers,
romus

Attachments (1)

linker.js (15.3 KB) - added by guest 7 years ago.
Patched linker.js [Linker Plugin]

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by guest

Patched linker.js [Linker Plugin]

comment:1 Changed 7 years ago by ray

  • Milestone changed from 0.96 to 0.95
  • Resolution set to fixed
  • Status changed from new to closed

rev [996]: I could not reproduce this error, could please check if this patch (I did it a bit simpler than you) fixes it?

comment:2 Changed 7 years ago by guest

  • Cc guest added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Thanks for replay. I've checked Your patch. There is other bug, now i've got something strange (in translation):
'udefined' is empty or isn't object.

I thing it's a matter of testing for array type (is an object but special, so test isn't simple).

This bug shows up in: IE 7.0.5730.13 (only with GoogleToolbar?, without any special changes, it's for testing only). Original bug shows up also on my clients PCs.

Cheers,
romus

comment:3 Changed 7 years ago by ray

  • Resolution set to fixed
  • Status changed from reopened to closed

rev [997]: still can't reproduce, and neither I understand why the simple checks don't work; but OK if it works better for you now

Note: See TracTickets for help on using tickets.